Bug 55598 - Kickstart upgrade installed mulitple kernels
Summary: Kickstart upgrade installed mulitple kernels
Status: CLOSED DUPLICATE of bug 55068
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-02 18:36 UTC by Peter Fales
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-08 16:13:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Upgrade.log file from 7.1 to 7.2 "kickstart upgrade" (35.97 KB, text/plain)
2001-11-05 20:20 UTC, Peter Fales
no flags Details

Description Peter Fales 2001-11-02 18:36:05 UTC
Description of Problem:

I had a 7.1 system which had two kernels in lilo.conf:  label=linux and
label=linux-old.
The linux image was linux-2.4.9-6 (from the latest kernel rpm) and
linux-old was the
old kernel from the 7.1 install CD.  After doing an "upgrade" kickstart",
my lilo.conf file
had entries for mulitple new kernels - I assume this is because several
kernel rpms
were installed.  

How Reproducible:

Only tested once 

Steps to Reproduce:
1.   Install vanilla 7.1 system.  Installed only the basic i686 kernel (no
enterprise,  no SMP, 
     etc.)
2.   Did a kickstart with the "upgrade" option   

Actual Results:

kernel-smp, kernel-enterprise,  and kernel were all installed and had
entried in lilo.conf

Expected Results:

Since the original system only had "kernel", I thought the upgrade should
have the same
package

Additional Information:

Comment 1 Brent Fox 2001-11-03 15:14:27 UTC
Can you attach your upgrade.log that the installer should have left in /tmp?  I
think XFree86 is pulling in the other kernel packages.  I can't duplicate this
on a vanilla upgrade from 7.1 to 7.2...did you install newer versions of XFree86
than what was shipped with 7.1?

Comment 2 Peter Fales 2001-11-05 20:20:48 UTC
Created attachment 36502 [details]
Upgrade.log file from 7.1 to 7.2 "kickstart upgrade"

Comment 3 Peter Fales 2001-11-05 20:22:34 UTC
You're right on both counts.  I forgot that my "vanilla" 7.1  installation also
had the chocolate sprinkles on top.  My 7.1 installation procedures includes
installing all RPMs from the ftp
site in the redhat 7.1 "updates" directory.   As far as I can tell, thought, the
XFree86 package
is the stock one from the 7.1 CD.  The updates are to some of the add-on
packages.

I've attached the updates.log file and I see that XFree86 is responsible for
pulling in the 
other kernels.  Is there any way to keep that from happening?


Comment 4 Brent Fox 2001-11-08 16:13:00 UTC
msw, is there anything we can do to prevent XFree86 (or other packages, for that
matter) from pulling in kernels (SMP, enterprise) that weren't already installed
on the system?


As far as I can tell, pulling in the other kernels doesn't hurt anything, but it
is a little annoying.

Comment 5 Brent Fox 2001-11-08 16:38:38 UTC
This is a dupe of bug #55068.

*** This bug has been marked as a duplicate of 55068 ***

Comment 6 Peter Fales 2001-11-08 18:51:32 UTC
In addition to the disk space used by the extra kernels, another annoying aspect
of this is that it creates lilo entries for all the kernels.  This is confusing
to users who suddenly start seeing extra choices on the boot menu and start
asking what they are for.



Note You need to log in before you can comment on or make changes to this bug.