Bug 555981 - Incorrect logrotate method
Incorrect logrotate method
Status: CLOSED DUPLICATE of bug 221073
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-16 02:44 EST by JW
Modified: 2010-07-09 08:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-09 08:45:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JW 2010-01-16 02:44:29 EST
Description of problem:
The method used in /etc/logrotate.d/httpd to start a new log file can result in loss of log entries


Version-Release number of selected component (if applicable):
httpd-2.2.14-1.fc13

How reproducible:
Always

Steps to Reproduce:
1. cat /etc/logrotate.d/httpd
  
Actual results:
Contains: /bin/kill -HUP `cat /var/run/httpd/httpd.pid 2>/dev/null` 2> /dev/null || true

Expected results:
Should contain: /usr/sbin/apachectl graceful || true

Additional info:
graceful is better!
Comment 1 Bug Zapper 2010-03-15 10:01:57 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Joe Orton 2010-07-09 08:45:33 EDT

*** This bug has been marked as a duplicate of bug 221073 ***

Note You need to log in before you can comment on or make changes to this bug.