Bug 55605 - kernel 2.4.9-7 constantly outputs messages to syslog about clock timer
kernel 2.4.9-7 constantly outputs messages to syslog about clock timer
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-02 15:12 EST by compwiz
Modified: 2007-04-18 12:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-28 11:07:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description compwiz 2001-11-02 15:12:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; MSIE 5.5; Linux)

Description of problem:
When running kernel 2.4.9-7 on my Asus A7A266 motherboard (ALi chipset), 
the following messages gets printed by the kernel every couple minutes, and
is very annoying. There's nothing wrong with my hardware, and this should
not be printed.

Nov  2 15:05:24 discovery kernel: probable hardware bug: clock timer
configuration lost - probably a VIA686a motherboard.
Nov  2 15:05:24 discovery kernel: probable hardware bug: restoring chip
configuration.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Turn on system.
2.Look at /var/log/messages or dmesg.
	

Additional info:
Comment 1 Alexei Podtelezhnikov 2002-01-08 02:36:03 EST
Souldn't you have 2.4.9-13 (instead of -7)? Yes, -13 is the official update 
release at ftp.redhat.com. -7 was never released, it was in rawhide, it has 
some extra debugging checks. Close the bug.
Comment 2 Arjan van de Ven 2002-01-08 04:46:05 EST
-7 was also released as official update before -13 was.
Anyway I'll kill this message for the next kernel we'll release.
Comment 3 Need Real Name 2002-01-28 11:07:18 EST
I didn't know that anyone else was experiencing this. I have the same MOBO,
and sought assistance from ASUS with no help forthcoming from them 
(lousy service ASUS has).

My experience didn't show until after I upgraded to the -13 kernel, though. 
It didn't show with the 2.4.7-10 or 2.4.9-7. (Actually, I don't know how I got the 
2.4.9-7 kernel, but I've been running the Redhat Network Update each time 
I get a kernel annoucement--It must have been pushed down with the updater.)

I haven't checked the logs since I installed the -13 kernel, but then, if 
it's been removed, I won't see it anyway.

Is it really a kernel issue? Or is the MOBO the problem?

--Greg
Comment 4 Arjan van de Ven 2002-02-11 12:05:43 EST
This message is removed in 2.4.9-21 at least.
It's basically a check for a bug in some chipsets that set the timer back to the
(windows) value of 18.2Hz. (Linux uses 100Hz). 
The kernel tries to detect this but sometimes it detects it wrong; no big deal
since setting it to 100 if it already was 100 is harmless.

Note You need to log in before you can comment on or make changes to this bug.