Bug 55609 - update packages have unresolved dependencies
update packages have unresolved dependencies
Product: Red Hat Linux
Classification: Retired
Component: semi (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Depends On:
  Show dependency treegraph
Reported: 2001-11-02 16:19 EST by Joe Harrington
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-11-07 21:52:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Joe Harrington 2001-11-02 16:19:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-6.2.10smp i686)

Description of problem:
The xemacs and semi packages posted recently claim to resolve a dependency
problem, but RPM still won't install them.
http://www.redhat.com/support/errata/RHBA-2001-135.html says:

   This update of xemacs contains apel-10.3 which is required for
   and wl-xemacs to work properly. 

   2. Problem description:

   xemacs in Red Hat Linux 7.2 contains apel-10.2, but semi-xemacs and
   wl-xemacs require apel-10.3 to build and function correctly. 

However, the posted updates will not install, because semi is looking for
apel >= 10.3 and apparently can't find it nor the fact that xemacs now
provides it (if indeed it does).

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.install all other updates
2.rpm -Uvh \
  xemacs-21.1.14-23.7.2.i386.rpm \
  xemacs-el-21.1.14-23.7.2.i386.rpm \
  xemacs-info-21.1.14-23.7.2.i386.rpm \
  semi-1.14.3-8.i386.rpm \

Actual Results:  error: failed dependencies:
        apel >= 10.3 is needed by semi-1.14.3-8

Expected Results:  Installation of all packages.

Additional info:

There is a bugzilla topic for "apel", but no package in 7.2.

The error happens even after I install *all* other packages (including
xemacs-* and semi-xemacs), and just try to install semi.

Comment 1 Bill Nottingham 2001-11-05 11:25:09 EST
Try installing the apel package from 7.2 - does that solve the problem?
Comment 2 Joe Harrington 2001-11-05 12:35:20 EST
I see now that apel is on the CD, but it is not installed with an "everything"
install.  I'm sure it will work fine when I install the component.  But...

I compared the packages actually installed in an "everything" install with the
full list, and I see 92 language-related packages that are not installed, and
kernels and X servers and X fonts that don't apply to me.  Fair enough, I
specified only en to be installed.  But, I also see 6 uninstalled packages that
do not appear to be language-related, at least according to their RPM info:


Why are these not installed in an "everything" install?  If the reason is
language-related, it should be included in the rpm description.


Comment 3 Jens Petersen 2001-11-07 21:52:36 EST
First comment, perhaps the generic errata advisory was not worded in the best
way in this case, but you only need to install semi-1.14.3-8 to use semi with
Emacs.  If you only need semi for XEmacs you only need to install semi-xemacs,
not semi.

The packages you mentioned that aren't installed in an everything installation,
are currently marked in comps as being Japanese specific.  Could you please file
that as a separate bug under the comps component?

Note You need to log in before you can comment on or make changes to this bug.