Bug 556101 - xen : does not adhere to Static Library Packaging Guidelines
xen : does not adhere to Static Library Packaging Guidelines
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Xen Maintainance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13VirtTarget
  Show dependency treegraph
 
Reported: 2010-01-16 09:47 EST by Michael Schwendt
Modified: 2010-06-03 05:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-03 05:00:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2010-01-16 09:47:55 EST
The package is in need of an update because it does not adhere to
the guidelines for packaging static libraries:

  http://fedoraproject.org/wiki/Packaging:Guidelines#Packaging_Static_Libraries

The -devel package contains both the shared and the static build of
a library. That makes it possible to link statically with the -devel
package as a build requirement instead of having to build-require a
special-purpose -static subpackage.

Correct would be to either disable/delete the static libraries at
build-time, or to %exclude them in the %files section, or to split off
a -static subpackage (if there is a compelling reason as why the static
libs should be made available).

Please consult the guidelines for the details.

[...]

xen-devel
    /usr/lib/libblktap.so  <=>  /usr/lib/libblktap.a
    /usr/lib/libflask.so  <=>  /usr/lib/libflask.a
    /usr/lib/libxenctrl.so  <=>  /usr/lib/libxenctrl.a
    /usr/lib/libxenguest.so  <=>  /usr/lib/libxenguest.a
    /usr/lib/libxenstore.so  <=>  /usr/lib/libxenstore.a
Comment 1 Michael Schwendt 2010-03-11 12:09:51 EST
* There is only one package in Fedora, which BuildRequires xen-devel and mentions "-static" in its build log: vhostmd
It links shared in the final compiler call.

* xenwatch : creates a non-verbose build log, but links shared with libxenstore

* xenner : creates a non-verbose build log, but links shared

* libvirt : links shared
Comment 2 Michael Schwendt 2010-06-03 05:00:48 EDT
Closed by: fedora-report-static-batch.py

Note You need to log in before you can comment on or make changes to this bug.