This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 556132 - virt-manager fails to connect to libvirt
virt-manager fails to connect to libvirt
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-16 12:39 EST by Valent Turkovic
Modified: 2010-01-20 08:40 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-18 08:16:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Virtual Machine Manager Connection Failure (41.55 KB, image/png)
2010-01-16 12:46 EST, Valent Turkovic
no flags Details

  None (edit)
Description Valent Turkovic 2010-01-16 12:39:02 EST
Description of problem:
I installed virt-manager and started it, and got an error saying:

Unable to open a connection to the libvirt management daemon.
Libvirt URI is: qemu:///system
Verify that:
 - The 'libvirtd' daemon has been started


I checked and saw that libvirt wasn't even installed, how come?

I installed it manually and started the service, then virt-manager started ok.

This is obviously not what users expect, I guess that libvirt should be installed as a dependency and started.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Valent Turkovic 2010-01-16 12:46:22 EST
Created attachment 384829 [details]
Virtual Machine Manager Connection Failure
Comment 2 Lubomir Rintel 2010-01-18 08:16:57 EST
Not a bug. You don't have to run libvirtd locally, you could connect to a remote server.
Comment 3 Daniel Berrange 2010-01-18 08:24:28 EST
FYI: if you had done  'yum groupinstall Virtualization' you would have got everything you need in one go. As Lubomir mentions, simply installing 'yum install virt-manager' doesn't bring in everything since it needs to be usable in a client scenario without any local virt technology install
Comment 4 Valent Turkovic 2010-01-18 14:39:09 EST
Thank you both for clarification, seams reasonable once you got it, but you can also understand how it seamed strange from my point of view. 

Thanks again.
Comment 5 Bastien Nocera 2010-01-20 08:40:47 EST
Maybe a clarification in the description would be useful?

Note You need to log in before you can comment on or make changes to this bug.