Bug 55615 - changing local passwd fails if ypbind is running
changing local passwd fails if ypbind is running
Status: CLOSED DUPLICATE of bug 55383
Product: Red Hat Linux
Classification: Retired
Component: passwd (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-02 16:53 EST by Akkana
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-02 16:53:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akkana 2001-11-02 16:53:40 EST
Description of Problem:
On 7.1 running ypbind, no shadow passwds, with several users (including
root) defined in /etc/passwd which override NIS entries of the same name, I
can't change the local passwords.

Version-Release number of selected component (if applicable):
passwd-0.64.1-4
linuxconf-1.24r2-10
ypbind-1.7-6

Steps to Reproduce:
Turn on NIS (/etc/init.d/ypbind start)
su
passwd root, type in new passwd, note error:
passwd: Authentication token manipulation error

linuxconf, click users, click change root passwd, type in a new passwd:
note no error but password isn't actually changed.  (Should the lack of
error message be a separate bug?)

Now turn off NIS (/etc/init.d/ypbind stop) and repeat steps.
Password does change.

Additional Information:
Note that only the local accounts are usable on the machine -- if you log
in as root, you need the local password.  So changing the password should
apply to the local account as well; it's not useful to try to change the
password for a remote account which you can't access from the local machine.
Comment 1 Joshua Buysse 2001-11-14 14:18:55 EST

*** This bug has been marked as a duplicate of 55383 ***

Note You need to log in before you can comment on or make changes to this bug.