Bug 556170 - [abrt] fails without cups-pk-helper installed
Summary: [abrt] fails without cups-pk-helper installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:08997608
: 592319 (view as bug list)
Depends On:
Blocks: 556512
TreeView+ depends on / blocked
 
Reported: 2010-01-16 22:27 UTC by Heiko Adams
Modified: 2010-05-14 15:58 UTC (History)
26 users (show)

Fixed In Version: 1.1.16-13.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 556512 (view as bug list)
Environment:
Last Closed: 2010-02-05 01:35:21 UTC


Attachments (Terms of Use)
File: backtrace (2.70 KB, text/plain)
2010-01-16 22:27 UTC, Heiko Adams
no flags Details

Description Heiko Adams 2010-01-16 22:27:13 UTC
abrt 1.0.3 detected a crash.

How to reproduce
-----
1. Open System-Config-Printer
2. Try to add a new printer


Attached file: backtrace
cmdline: python /usr/share/system-config-printer/system-config-printer.py
component: system-config-printer
executable: /usr/share/system-config-printer/system-config-printer.py
kernel: 2.6.31.9-174.fc12.i686
package: system-config-printer-1.1.16-8.fc12
uuid: 08997608

Comment 1 Heiko Adams 2010-01-16 22:27:16 UTC
Created attachment 384860 [details]
File: backtrace

Comment 2 Tim Waugh 2010-01-18 15:54:59 UTC
Fixed upstream.  Work-around is to install cups-pk-helper.

Comment 3 Tim Waugh 2010-01-18 16:19:32 UTC
Also affects Fedora 11.

Comment 4 Fedora Update System 2010-01-18 17:45:39 UTC
system-config-printer-1.1.16-9.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/system-config-printer-1.1.16-9.fc11

Comment 5 Fedora Update System 2010-01-18 17:46:29 UTC
system-config-printer-1.1.16-9.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/system-config-printer-1.1.16-9.fc12

Comment 6 Fedora Update System 2010-01-19 19:33:50 UTC
system-config-printer-1.1.16-9.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0755

Comment 7 Fedora Update System 2010-01-19 19:39:56 UTC
system-config-printer-1.1.16-9.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2010-0776

Comment 8 Tim Waugh 2010-01-22 09:21:39 UTC
*** Bug 557695 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2010-01-22 22:34:32 UTC
system-config-printer-1.1.16-11.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2010-0776

Comment 10 Fedora Update System 2010-01-22 22:36:40 UTC
system-config-printer-1.1.16-11.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0755

Comment 11 Ejner Fergo 2010-01-26 13:16:05 UTC
Updating to:

system-config-printer-libs-1.1.16-11.fc12.x86_64
system-config-printer-udev-1.1.16-11.fc12.x86_64
system-config-printer-1.1.16-11.fc12.x86_64

fixed the crashing. New printer added without problems, thanks!

Only "issue" I have, is typing and entering the root-password twice. 
1. time when pressing "New"
2. time when adding/confirming the printer

Comment 12 Milan Kerslager 2010-01-26 16:12:21 UTC
Confirming that system-config-printer-1.1.16-11.fc12.x86_64 works even package from comments #2 (cups-pk-helper) has been removed from the system.

Comment 13 Fedora Update System 2010-01-27 01:03:23 UTC
system-config-printer-1.1.16-13.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0755

Comment 14 Fedora Update System 2010-01-27 01:04:24 UTC
system-config-printer-1.1.16-13.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2010-0776

Comment 15 Niels 2010-01-31 14:00:18 UTC
-13 fixed the crash for me.

Comment 16 Fedora Update System 2010-02-05 01:34:37 UTC
system-config-printer-1.1.16-13.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2010-02-05 01:36:33 UTC
system-config-printer-1.1.16-13.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Tim Waugh 2010-05-14 15:58:45 UTC
*** Bug 592319 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.