Bug 556202 - [RFE] Improve DHCPv6 logging
[RFE] Improve DHCPv6 logging
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-16 23:11 EST by Frank Crawford
Modified: 2014-01-18 07:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-18 07:54:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
DHCPD output for both DHCP and DHCPv6 from /var/log/messages (8.06 KB, text/plain)
2010-01-16 23:11 EST, Frank Crawford
no flags Details

  None (edit)
Description Frank Crawford 2010-01-16 23:11:50 EST
Created attachment 384877 [details]
DHCPD output for both DHCP and DHCPv6 from /var/log/messages

Description of problem:
The logging for DHCPv6 only provides minimal information about the messages, and is far less than that provided for DHCP for IPv4 transactions.

Version-Release number of selected component (if applicable):
dhcp-4.1.0p1-13.fc12.i686

How reproducible:


Steps to Reproduce:
1. grep dhcpd /var/log/messages
2.
3.
  
Actual results:
Messages for DHCPREQUEST, DHCPACK. DHCPDISCOVER and DHCPOFFER are for IPv4 and specify enough information to find requesting host and offered address.

Solicit, Request and Sending messages are for IPv6 and only list IPv6 addresses allocated temporarily and specifically for the transaction which are not able to be traced back to the requesting host or finding out the offered address, from what is in the logs.  There is also no indication in the DHCPv6 replies if the message is an ACK or a NAK or any other status.

Expected results:
Similar abilities for IPv4 and IPv6.

Additional info:
For DHCPv6 it is probably necessary to print out some of the DHCPv6 options, which is where the real details are, and we may still be stuck with Client-ID/IA-NA, but it is better that an temporary address currently reported.

See details from a mixture of IPv4 and IPv6 output in the attached list.
Comment 1 Jiri Popelka 2011-04-21 07:00:12 EDT
Similar request on dhcp-users mailing list:
https://lists.isc.org/pipermail/dhcp-users/2011-April/013068.html
Comment 2 Jiri Popelka 2014-01-18 07:54:19 EST
ISC claims there should be some DHCPv6 logging improvements in dhcp-4.3 (rawhide/Fedora 21). Please give it a try (I haven't tried it myself yet) and if you're still not happy with it sugest more improvements at dhcp-bugs@isc.org because this isn't something I'd want to add downstream.
Comment 3 Frank Crawford 2014-01-18 07:58:40 EST
Sure, I understand that and agree.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.