Bug 556211 - Build fails when SELINUX disabled
Build fails when SELINUX disabled
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-17 02:04 EST by JW
Modified: 2010-01-18 04:15 EST (History)
1 user (show)

See Also:
Fixed In Version: pam-1.1.1-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-18 04:15:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JW 2010-01-17 02:04:15 EST
Description of problem:
When building rpms without SELINUX the build fails because of a fault in spec file.

Version-Release number of selected component (if applicable):
pam-1.1.0-7

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --without selinux -ba pam.spec

Actual results:
1. ERROR pam_sepermit did not build a module.

Expected results:
no erros expected

Additional info:
Need to patch pam.spec with:
         [ ${dir} = "modules/pam_selinux" ] && continue
+        [ ${dir} = "modules/pam_sepermit" ] && continue

Note You need to log in before you can comment on or make changes to this bug.