This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 55624 - 2.4.13-0.3 - unresolved symbols in ldev_mgr module
2.4.13-0.3 - unresolved symbols in ldev_mgr module
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-02 19:47 EST by Tim Clymo
Modified: 2015-01-04 17:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-29 23:24:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Clymo 2001-11-02 19:47:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
rpm --rebuild kernel-2.4.13-0.3.src.rpm|grep depmod:
depmod: *** Unresolved symbols in
/var/tmp/kernel-2.4.13-0.3-root/lib/modules/2.4.13-0.3BOOT/kernel/drivers/evms/ldev_mgr.o
depmod: 	gendisk_head


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.See description
2.
3.
	

Actual Results:  Kernel build moans about unresolved symbols

Additional info:
Comment 1 Bill Crawford 2001-11-14 05:47:48 EST
FWIW deleting the offending modules cures the error message, but is obviously
not much help if anyone wants to use it :o)

Looks like a missing EXPORT_SYMBOL(gendisk_head) in genhd.c
Comment 2 Arjan van de Ven 2001-11-14 05:55:06 EST
Not quite; that symbol is not available for modules for a good reason:
there are access functions for the list in question which take care of proper
locking; evms accesses it directly while violating the locking rules for it....
IBM is fixing it in evms
Comment 3 Bill Crawford 2001-11-14 06:23:36 EST
Ah.

Note You need to log in before you can comment on or make changes to this bug.