Bug 55631 - resolver doesnt recognice LOCALDOMAIN
resolver doesnt recognice LOCALDOMAIN
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-03 01:40 EST by Helmut Wirth
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-21 22:21:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Helmut Wirth 2001-11-03 01:40:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
Starting with rh 7.2, the resolver doesn4t seem to use the LOCALDOMAIN
environment variable longer, instead the searchlist setting in
resolv.conf is used in every case.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set searchlist parameter in resolv.conf to "olddomain.com"
2. export LOCALDOMAIN="newdomain.com"
3. ping www (of course, hosts "www.olddomain.com" and
   "www.newdomain.com" must exist)

	

Actual Results:  www.olddomain.com answers.	

Expected Results:  www.newdomain.com should answer.

Additional info:
Comment 1 Ulrich Drepper 2003-04-21 22:21:10 EDT
This is not an issue of not recognizing LOCALDOMAIN, it has to do with ping
being a SUID binary.  LOCALDOMAIN is an unsecure variable which is ignored (or
even eliminated) in SUID/SGID binaries.  LOCALDOMAIN works fine for non-SUID
binaries and ping run as root.  This is a security feature, not a bug.

Note You need to log in before you can comment on or make changes to this bug.