Bug 55645 - (SCSI AIC7XXX)7.2 Installer hangs on aic7xxx loading
(SCSI AIC7XXX)7.2 Installer hangs on aic7xxx loading
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-11-03 18:32 EST by Need Real Name
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:39:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-03 18:32:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
Installer halts at "aic7xxx loading"
AMD K6-2 300,128M, SiS 5591 chipset, Adaptec 7850 PCI SCSI (IRQ 11)with a 
Plextor burner hanging on it, PCI Ethernet, PCI SB Live!,,  2 IBM hds, 
Memorex IDE CD-ROM
Alt F4 yields cables are OK
<6> SCSI0 Adaptec AHA274x/284x/294x
<4> <Adaptec AIC-7850 Host Adaptor>
<4> Abort command due to timeout pid 0,scsi 0, channel 0,id 0, lun 02
<4> scsi bus is being reset for host 0 channel 0
<4> scsi host 0 channel 0 reset (pid 0)timeout
last two lines repeat

I've tried 'linux ide=nodma'
Just flashed my bios, no change

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.boot off of IDE CDROM (located as secondary slave)

Actual Results:  Hangs on 'aic7xxx loading'

Expected Results:  Load the Adaptec driver and proceed

Additional info:
Comment 1 Need Real Name 2001-11-03 18:35:14 EST
The HDs are IDE
Comment 2 Daniel Hammer 2001-11-04 05:28:36 EST
Had the same problem for the first 2 very early versions of 2.4 kernel, when
the "old" aic7xxx driver was replaced by the new present kernel driver. 
I had a Yamaha burner on it (threw it away 'n don't recommend it) with the same
result as you get. 
Even worse; when rebooting my machine the burner disappeared from the setting 
in the the SCSI-BIOS and I had to reconfigure the SCSI-bus setting.
Maybe you try the following: take out the power supply from the SCSI burner and
install RH 7.2 as you like it. Then compile your own kernel with the _old_
aic7xxx driver and install it, power down your machine, put again the power
supply to the SCSI burner and try to reboot your system. This worked for me
though I know it is not a brilliant solution.
Now I replaced my Yamaha SCSI burner by a much cheaper ATAPI one and it works
Comment 3 Doug Ledford 2001-11-06 15:53:54 EST
Try using the new aic7xxx driver on your system.  To use it, boot the installer
with the option noprobe and then when asked about where your media is, answer
local CD-ROM, then when prompted to add a device, add a SCSI device and then
select the "New Adaptec ...." from the list (you will have to scroll all the way
down to the N's, don't select any of the Adaptec options listed in the A's
portion of the list).  Report the results back here please.
Comment 4 Need Real Name 2001-11-08 18:53:52 EST
Using the experimental Adaptec driver seemed to work and permitted a smooth 
I installed all of the packages then rebooted.
Now, on boot up it hangs on "Entering Red Hat Interactive Press 'I' to continue"
I didn't notice any error messeges preceding this portion of startup.
It hangs right there every time.  Pressing 'I' does nothing. Alt F-4 nothing. 
CTL ALT DEL, nothing. Wait 15 minutes, nothing. Hard restart. Have not tried to 
re-install yet.
RH 7.2 installs and running works great if I just unplug the Adaptec card 
before I start.  But I'd like to use the Plextor burner it's attached to.
Comment 5 Bugzilla owner 2004-09-30 11:39:14 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.