Bug 55648 - The links package doesn't include translations
Summary: The links package doesn't include translations
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: links   
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-04 01:03 UTC by Christian Rose
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-04 01:04:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christian Rose 2001-11-04 01:03:59 UTC
The "links" package in Red Hat Linux 7.2 seems to be lacking the
translations that the source tarball has (in the form of the intl/*.lng
files). Thus, links in RHL 7.2 is unfortunately only available in English,
while the original links is not.

Comment 1 Bernhard Rosenkraenzer 2001-11-05 12:19:21 UTC
By any chance, did you file this bug report by just looking at the file list? 
 
It works for me, and if I've understood the links i18n system correctly, the *.lng files are included in the links binary itself (yes, it's nonstandard and arguably broken, but it works). 
 
 


Comment 2 Christian Rose 2001-11-05 13:18:07 UTC
The reason I reported this was that I didn't automatically get links in Swedish,
which was what I expected. I suspected this was due to the translation files not
being included, when looking at the file list.
However, when I tested it now it worked if I manually switch the language from
English to Swedish, and the character encoding from 7-bit ASCII to iso-8859-1,
in the menu. Somehow, I expected links to honor the locale environment
variables, but it seems it does not, and my own faulty memory seems to be the
culprit, as this was probably always the case.

Comment 3 Bernhard Rosenkraenzer 2001-11-05 13:20:56 UTC
Links never supported $LANG or any standard way of localization. I'm taking this up with its maintainer. 



Note You need to log in before you can comment on or make changes to this bug.