Bug 556492 - transmission-1.77-1.fc12 crashed when trying to save a blocklist to disk when the disk is full
Summary: transmission-1.77-1.fc12 crashed when trying to save a blocklist to disk when...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: transmission
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Rahul Sundaram
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ee4822f0fb2601e9c0bc291452b...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-18 15:41 UTC by Michael Closson
Modified: 2010-04-19 16:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-19 16:26:43 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (14.57 KB, text/plain)
2010-01-18 15:41 UTC, Michael Closson
no flags Details

Description Michael Closson 2010-01-18 15:41:46 UTC
abrt 1.0.3 detected a crash.

How to reproduce
-----
1. Start transmission.
2. Click "Downloads" button

Comment: I has some torrents already in the system.
Attached file: backtrace
cmdline: transmission
component: transmission
executable: /usr/bin/transmission
kernel: 2.6.31.9-174.fc12.i686.PAE
package: transmission-1.77-1.fc12
rating: 4
reason: Process was terminated by signal 11 (Segmentation fault)

Comment 1 Michael Closson 2010-01-18 15:41:48 UTC
Created attachment 385127 [details]
File: backtrace

Comment 2 Michael Closson 2010-01-18 17:45:32 UTC
I was over my disk space quota.  That is probably the root cause.

Comment 3 Charles Kerr 2010-04-19 16:03:11 UTC
> I was over my disk space quota.  That is probably the root cause.   

Yep, we're trying to fwrite() to a NULL file pointer.  Thanks for the hint. :)

Comment 4 Charles Kerr 2010-04-19 16:26:43 UTC
Fixed upstream; scheduled for 1.92 + 1


Note You need to log in before you can comment on or make changes to this bug.