Bug 55654 - Backspace Delete Problem
Backspace Delete Problem
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-03 21:33 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-12 16:32:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-03 21:33:40 EST
Description of Problem:
In the Gnome Terminal, both the Backspace and Delete
keys send Backspace (^H).

Version-Release number of selected component (if applicable):
gnome-libs-1.2.13-16

How Reproducible:
Need to have the Backspace/Delete keys work "correctly."
Whether relevant or not, run /usr/bin/fix_bs_and_del on
startup. Open Gnome Terminal. With the swap backspace and
delete option UNCHECKED, both the Backspace and Delete
keys send Backspace (^H), REGARDLESS of the status of
the "Delete generates DEL/^H" checkbox.

Someone from one of the Gnome mailing lists claims
that the problem comes from libzvt, and that the
current version of gnome-libs does not have that
problem.
Comment 1 Havoc Pennington 2001-11-04 12:18:42 EST
Does the gnome-libs package at ftp://people.redhat.com/hp/gnomehide resolve this
issue for you?
Comment 2 Need Real Name 2001-11-05 20:12:06 EST
Nope. I installed it (and even rebooted the machine),
and it still behaves the same.
Comment 3 James Henstridge 2001-12-02 01:38:43 EST
I don't know if this is related to a problem I was seeing on a box with a
slightly old video card (ie. not supported by XF4) that I installed 7.2 on.  It
was using the XF3 SVGA server instead.

Both the backspace and delete keys were generating the Delete keysym. 
Mailaccount200001: you can test if this is the case on your box with the xev
program (just run it, focus the window, and press the backspace and delete keys,
and look at the output on the console).

Running the following fixed the problem:
  xmodmap -e "keycode 22 = BackSpace"

If the two keys are producing the same keysym, no combination of settings in
gnome-terminal is going to help :(
Comment 4 Need Real Name 2001-12-04 02:54:36 EST
You have it backwards. I need to run:

xmodmap -e "keycode 107 = Delete"

Yes, that will 
correct the problem, but Red Hat has the
setup wrong (why I entered it as a bug in the first 
place).

It seems very bad to have both backspace and delete set
to backspace, and then 
hoping that most users won't notice
it because they will use the swap backspace and 
delete
option in Gnome Terminal.
Comment 5 Havoc Pennington 2001-12-04 12:27:11 EST
Just to clarify, you had both keys sending Backspace if you looked at them in "xev"?

Reassigning to X, this is a bug in some of the X keymaps.
Comment 6 Need Real Name 2001-12-04 20:13:21 EST
Yes.

Pressing backspace gives:

keycode 22 (keysym 0xff08, BackSpace)

and the delete key gives:

keycode 107 (keysym 0xff08, BackSpace)

I used the dvorak layout, but that doesn't matter.
The files in /usr/share/xmodmap all contain:

keycode  22 = BackSpace Delete

But very few of them contain any definition for
keycode 107.
Comment 7 Mike A. Harris 2002-03-12 15:27:02 EST
I have not seen BS/DEL bugs in X in KDE/GNOME/xterm/whatever for many
many years personally in any applications other than emacs and perhaps
a few others.  These were all application issues not X issues.  Using
the info above I am unable to reproduce any problems in GNOME with BS/DEL
using a default setup.

The files referenced above are not part of XFree86.

[root@asdf root]# rpm -qf /usr/share/xmodmap/xmodmap.fi
gnome-applets-1.4.0.1-6

Reassigning to relevant component.
Comment 8 Havoc Pennington 2002-03-12 16:32:54 EST
Mike, the original problem was that both backspace and delete sent the backspace
keysym - this is an X bug if it happens in our packages, and NOTABUG if it
doesn't happen in our packages. In any case it has nothing to do with gnome-applets!
Just close the bug if our packages do not ship with the keysyms mangled this way.
(Note that the reporter is using Dvorak i.e. a non-default keymap.)
Comment 9 Mike A. Harris 2002-05-30 02:11:27 EDT
Closing bug WONTFIX.  If there is an actual bug here in dvorak, it is
only affecting a very very small number of people.  It is something that
should be fixed by upstream if it exists IMHO, as it is unlikely to be
a Red Hat specific issue.

Note You need to log in before you can comment on or make changes to this bug.