Bug 55658 - firewire disks need edit to rc.sysinit to work at boot
Summary: firewire disks need edit to rc.sysinit to work at boot
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-04 05:20 UTC by Seth Vidal
Modified: 2014-03-17 02:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-05 21:08:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Seth Vidal 2001-11-04 05:20:19 UTC
Description of Problem:
if you have a firewire disk - there is no way to get it to autoload the
ohci1394 and sbp2 modules to mount the disk from fstab

Therefore you need to add something in /etc/rc.d/rc.sysinit.
I added a modprobe of ohci1394 and sbp2 if sbp2 was listed in /etc/modules.conf


this is the only way I found to be able to get firewire disks to work
automatically when rebooting.

Comment 1 Bill Nottingham 2001-11-05 15:33:16 UTC
That's not really a good way to do it; rc.sysinit needs *less* HW init code, not
more. Are firewire disks hot-pluggable?

Comment 2 Seth Vidal 2001-11-05 15:37:12 UTC
do you mean will the system pick them up if they are plugged in? Not so far as I
can see. If the firewire controller modules are loaded then yes they normally
get picked up - but I can't figure out how to make the ieee1394 and ohci1394
modules get loaded automatically.

I'm open to suggestions though.


Comment 3 Rudi Heitbaum 2002-06-26 14:01:47 UTC
The firewire disk I am using are hot pluggable, with the same problem.

/sbin/modprobe sbp2 

fails with:

/lib/modules/2.4.9-34/kernel/drivers/ieee1394/sbp2.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters
/lib/modules/2.4.9-34/kernel/drivers/ieee1394/sbp2.o: insmod
/lib/modules/2.4.9-34/kernel/drivers/ieee1394/sbp2.o failed
/lib/modules/2.4.9-34/kernel/drivers/ieee1394/sbp2.o: insmod sbp2 failed

even with the lines

add below module sbp2 ohci1394

in the modules.conf (sbp2 is dependant on ohci1394 even though not in the
modules.dep)

Comment 4 Need Real Name 2002-09-05 21:08:40 UTC
I use a firewall hard disk box and it is fine, however kudzu doesn't detect my
firewire card, and that i have to do modprobe myself.

Preferably if we can detect the firewire card in the boot sequence and enable
hotplug like usb

Comment 5 Bill Nottingham 2002-09-05 21:43:21 UTC
This is done in the current beta.


Note You need to log in before you can comment on or make changes to this bug.