Bug 55662 - anaconda produces 'traceback' error
anaconda produces 'traceback' error
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-04 02:33 EST by Drew Poulin
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-13 15:35:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error anaconda produces while copying system files to disk (10.10 KB, text/plain)
2001-11-04 02:35 EST, Drew Poulin
no flags Details

  None (edit)
Description Drew Poulin 2001-11-04 02:33:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.2) Gecko/20010726
Netscape6/6.1

Description of problem:
anaconda produces 'traceback' error when copying files to disk

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Partition disk
2. Enter network and package info
3. Disk is formatted and the error subsequently occurs 
	

Actual Results:  Get an error message, which I saved to a floppy as instructed.

Expected Results:  System files should have been copied to the disk, and I
should have been able to get something done today

Additional info:

Trying to install RH7.1 on Toshiba 2805-S603 laptop, 30 GB HD, 256 MB RAM,
Windows 98 already installed.  Have used fips to shrink Windows partition
and fdisk to add add root and swap partitions.  After formatting the disk,
and while copying system files to it (I think), anaconda spits out the
following error and quits.  Help.


Traceback (innermost last):
  File "/usr/bin/anaconda", line 520, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 1126, in run
    rc = apply (step[1](), args)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 551, in __call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1782, in
doInstall
    self.fstab.umountFilesystems(self.instPath)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/fstab.py", line 632, in
umountFilesystems
    isys.umount(mntPoint, removeDir = 0)
  File
"/mnt/redhat/test/qa0408.4/i386/RedHat/instimage/usr/lib/anaconda/isys.py",
line 134, in umount
    raise ValueError, "isys.umount() can only umount by mount point"
ValueError: isys.umount() can only umount by mount point
Comment 1 Drew Poulin 2001-11-04 02:35:57 EST
Created attachment 36321 [details]
error anaconda produces while copying system files to disk
Comment 2 Brent Fox 2001-11-05 23:36:12 EST
Can you try the install again, but this time don't set a mount point for any DOS
partitions.  After the install, you can set mount points for them in the
/etc/fstab file.  Does this help?
Comment 3 Drew Poulin 2001-11-10 17:11:54 EST
As advised, I deleted the mount point for the DOS partition, and this did
eliminate the error I reported earlier.  But now I get a new error:

"An error occured (sic) transferring the install image to your HD.  Your are
probably out of disk space."

No, I'm not out of disk space.  I have half of a 30 GB HD set aside for RH
Linux:  256 MB for a swap partition and the remainder for my root partition.  

Any other suggestions?
Comment 4 Brent Fox 2001-11-13 15:35:38 EST
When the error message appears, press <Ctrl><F2>.  Then type "mknod hda".  Then
type "fdisk -l hda".  Can you attach the output of that to the bug report?  I'm
curious to know how big the partitions that you made were.
Comment 5 Brent Fox 2001-12-08 12:34:20 EST
Closing due to inactivity.  Please reopen if you have more information.
Comment 6 Drew Poulin 2001-12-27 17:59:39 EST
Problem resolved.  I was able to install RH 7.2 without problems after running
defrag and fips again.  When run the second time, fips exited immediately after
simply reporting that I had no more disk space available.  I would guess that my
disk had not been completely defragmented when I ran fips the first time.  There
may have been some disk activity that I was unaware of between the time that I
defragged and the time that I ran fips (first time).  

Thank you for following up.

Note You need to log in before you can comment on or make changes to this bug.