Bug 55663 - locale config screws up rc.d/* files
locale config screws up rc.d/* files
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.2
i686 Linux
high Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-04 03:03 EST by Cesar Shen
Modified: 2014-03-16 22:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-05 15:48:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cesar Shen 2001-11-04 03:03:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
System language and locale changed from English to Simplified Chinese then
changed it back to English cause system screwed up rc.sysinit and some
rc.d/* and rc5.d/*.  typically when I open a terminal, got error message
"bash: 9: command not found.  Also after language and locale changed back
to English, cann't resize any window, seems gnome screwed up also. gedit,
VIM that can input chinese app crashes in English language and locale.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.when login, choose language simplified chinese
2.login, and choose yes for system warning message saying change locale to
simplified chinese
3.logout
4.choose language English and locale English, log back in
5. maybe need to do it serval times
	

Additional info:
Comment 1 Owen Taylor 2001-11-04 13:52:41 EST
A) Why do you think rc.d/* was "screwed up"? A login as a user
   can't change those files. I dont' know any reason why
   logging in as root would affect those files?

B) Did you log in as a user or as root?

B) Did you actually run the "locale_config" command, or was
   this the option to change the locale in GDM?
Comment 2 Cesar Shen 2001-11-04 14:33:11 EST
A) After changed language and locale, when system boots up, there are lots of 
error messages saying "/etc/rc.sysinit: 9: command not found" and other rc.d 
and rc5.d files like rc, rc5.d/S56xinetd etc.

B) yes, I did login as root

C) I used this option in GDM
Comment 3 Owen Taylor 2001-11-04 14:54:49 EST
I don't think this is related to changing your locale through GDM.
Changing the locale in GDM involves:

 - Changing a GDM config option
 - Setting environment variables (LANG,GDM_LANG) when starting
   the session

It doesn't change anything that would affect bootup. Are you
sure you didn't accidentally add something to /root/.bashrc
while runnng as root? 

If you didn't do it yourself, it's possible that something
in our chinese environment has an "automatically edit 
your bash configuration" setup that causes problems when
run for root.

I'm assigning this to initscripts for now since that's where
other similar bug reports would probably have been reported.
Comment 4 Bill Nottingham 2005-04-05 15:48:04 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

I haven't seen any other reports of this in bugzilla.

Note You need to log in before you can comment on or make changes to this bug.