Bug 556751 - ntsysv does not list 'clamd.scan'
Summary: ntsysv does not list 'clamd.scan'
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: chkconfig
Version: 12
Hardware: All
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 567387
TreeView+ depends on / blocked
 
Reported: 2010-01-19 10:11 UTC by Eli Barzilay
Modified: 2014-03-17 03:21 UTC (History)
6 users (show)

(edit)
Clone Of:
: 567387 (view as bug list)
(edit)
Last Closed: 2010-03-04 15:42:20 UTC


Attachments (Terms of Use)

Description Eli Barzilay 2010-01-19 10:11:03 UTC
Description of problem:

On a fresh F12 installation, clamd.scan doesn't seem to start when booting.
Possibly related, I don't see it in the list of services in
system-config-services and in ntsysv.  When running the former, there are
repeated error messages that say "KeyError: dbus.String(u'clamd.scan')".
I've been trying to figure out what might cause the problem, including stracing
a run of ntsysv -- which scans all the scripts in /etc/init.d/ but mysteriously
ignores "clamd.scan".  The only guess I have so far is that this is the only
file that has a period in its name.

Version-Release number of selected component (if applicable):
clamav-scanner-sysvinit-0.95.3

How reproducible:
always

Steps to Reproduce:
boot, or run ntsysv, or system-config-services
  
Actual results:
clamd.scan does not start by itself, and does not appear as a service.

Expected results:
Should start, should appear.

Additional info:
I didn't try to fix this, because I don't have enough experience tweaking
init scripts, and because this is a running server that is in active use.
So perhaps the problem is elsewhere.

Comment 1 Enrico Scholz 2010-02-21 14:05:18 UTC
seems to be an ntsysv problem; 'chkconfig ...' works as expected:

# LANG=C chkconfig --list | grep clamd
clamd.scan      0:off   1:off   2:off   3:off   4:off   5:off   6:off
# LANG=C chkconfig clamd.scan on
# LANG=C chkconfig --list | grep clamd
clamd.scan      0:off   1:off   2:on    3:on    4:on    5:on    6:off

Comment 2 Bill Nottingham 2010-02-22 20:06:14 UTC
http://git.fedorahosted.org/git/?p=chkconfig.git;a=commitdiff;h=4f6940058d8741379a79c88f51aec9ad3c29a6df

Will get pushed to rawhide/F13 at some point in the near future.

Comment 3 Bill Nottingham 2010-03-04 15:42:20 UTC
Fixed in 1.3.45-1.

Comment 4 Fedora Update System 2010-03-04 15:49:00 UTC
chkconfig-1.3.45-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/chkconfig-1.3.45-1.fc13

Comment 5 Fedora Update System 2010-03-11 13:27:16 UTC
chkconfig-1.3.45-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.