Bug 556779 - Desktop Clipping with SM722 graphics adapter [NEEDINFO]
Desktop Clipping with SM722 graphics adapter
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
5.4
i386 Linux
low Severity medium
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Patch, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-19 06:56 EST by Girish Shirasat
Modified: 2014-06-02 09:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:22:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (gshirasat)


Attachments (Terms of Use)

  None (edit)
Description Girish Shirasat 2010-01-19 06:56:38 EST
Description of problem:

With RHEL 5.2-5.4 distributions on SM722 graphics adapter, the top of the GNOME desktop is getting clipped. As this issue was not seen on RHEL 5.0, there was something which was added later either in the Xserver or the SM722 driver which was causing this issue. As all the RHEL 5.x updates were having the same version of the SM722 driver ie 1.4.1, the driver was ruled out. I then started replacing some of the relevant RHEL 5.4 Xserver shared libraries with those of RHEL 5.0. In this process it turned out that the INT10 library (libint10.so) was the one which was causing the issue. On comparing the sources of the INT10 library between RHEL 5.0 and 5.4, it turned out that in the file helper_exec.c , the relevant lines which were actually causing this issues were in the functions used to perform PCI configuration long read/writes ie
in functions "pciCfg1in" and "pciCfg1out".

To be more specific:

In Function pciCfg1in:
RHEL 5.4: *val = pciReadLong(Int10Current->Tag, OFFSET(PciCfg1Addr));
RHEL 5.0: *val = pciReadLong(TAG(PciCfg1Addr), OFFSET(PciCfg1Addr));

In Function pciCfg1out:
RHEL 5.4: pciWriteLong(Int10Current->Tag, OFFSET(PciCfg1Addr),val);
RHEL 5.0: pciWriteLong(TAG(PciCfg1Addr), OFFSET(PciCfg1Addr), val);

On using the RHEL 5.0 version of PCI address creation, I was able to get full desktop without any clipping. Is this a bug or was this change done for some reason ?

Version-Release number of selected component (if applicable):


How reproducible:
Normal Install of RHEL 5.2-5.4 using a SM722 based graphics adapter with resolution set to 1280x1024 shows this issue.

Steps to Reproduce:
1.Install RHEL 5.4 on system with SM722 graphics adapter 
2.Set the resolution to 1280x1024.
3.
  
Actual results:
Top of the GNOME desktop gets clipped

Expected results:
Full desktop needs to be visible

Additional info:
Comment 1 RHEL Product and Program Management 2014-03-07 08:54:00 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 2 RHEL Product and Program Management 2014-06-02 09:22:15 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.