Bug 55678 - (USB KEYBOARD)usb keyboard not recognized during install of red hat 7.2 on compaq presario 7000 with amd 1 ghz processor.
(USB KEYBOARD)usb keyboard not recognized during install of red hat 7.2 on co...
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-11-04 12:32 EST by joels
Modified: 2007-04-18 12:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-01-05 15:29:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
usbview output (2.85 KB, text/plain)
2001-12-24 10:52 EST, Bernard So Kua
no flags Details

  None (edit)
Description joels 2001-11-04 12:32:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)

Description of problem:
The second screen of the 7.2 installation process does not recognize any 
reasonable keyboard. My keyboard is USB on a compaq presario 7000. The 
machine including the mouse and keyboard, worked flawlessly under red hat 
7.1. The first time through the installer I did not test the keyboard as 
it worked under 7.1. After the upgrade process to 7.2 I was presented the 
graphical logon at which point I discover the keyboard does not work. I 
can't enter any keys or set caps or num lock. I re-booted 7.2 cd1 and at 
the second screen tried to select and test keyboards none of which were 
recognized. My presario has usb ports on the front and back of the 
machine, I tried them all with no luck. I tried a usb to serial adapter 
which also did not work, to my surprise. I have two hard drives in this 
machine, I did not load LILO or grub during the upgrade. I have windows on 
one hard drive, Linux on the other. I boot Linux from diskette. The mouse 
and keyboard work under windows so I know they are functional. During the 
boot process I get numerous messages that 
read 'usb_control/bulk_msg:timeout', eventually boot proceeds to the 
graphical login but the keyboard does not work.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.boot red hat 7.2 cd 1 (purchased set of cd's not downloaded)
2. choose english
3. try to choose and test keyboard. No keyboard will test successfully.

Actual Results:  usb keyboard not recognized. I continued with the upgrade 
since only a mouse is needed and cannot login at the graphical login 

Expected Results:  I should have been able to select and successfully test 
a keyboard and login at the prompt.

Additional info:

also tried turning usb legacy support off in the bios with no success. The 
Compaq bios is current I believe.
Comment 1 Brent Fox 2001-11-05 23:47:29 EST
This is the second report I've heard of problems with USB keyboards.  I'm
surprised because we tested a number of USB keyboards and mice.  Does text mode
work with the keyboard?
Comment 2 joels 2001-11-06 23:34:42 EST
I am not entirely sure what you mean by 'text mode' as I am new to Linux. I 
opened this report as directed by Red Hat Technical support. I can tell you that the 
keyboard does not work at all, i.e. caps/num lock does not work nor does any key 
on the keyboard. As directed by Red Hat Technical support I updated the kernel, 
well I think I did anyway, to 2.4.9-13 this evening using up2date. Red Hat Technical 
support didn't tell me what to do after the up2date process but I tried disconnecting 
the serial keyboard and plugging in the USB keyboard but re-boot via the boot 
diskette I made with the new kernel parameter (I don't use LILO or GRUB but boot 
from diskette...it's a long story) did not change anything, i.e. still no USB keyboard. 
I did notice that in addition to the 'usb_control/bulk_msg: timeout' messages I get 
'usb-uhci.c interrupt status 2 frame# 1355'. The message goes by quickly so I 
have to copy it quickly so the format may not be exact.
Comment 3 Brent Fox 2001-11-07 15:00:10 EST
By 'text mode', I mean the text installer instead of the graphical one.  You can
use the text mode installer by typing 'text' at the bootup screen from the cd. 
But it sounds like you've already got the system installed...how did you do that
without a keyboard?
Comment 4 joels 2001-11-07 22:32:38 EST
Well to the best of my recollection you only need a mouse from the second screen 
until the end. I just clicked my way through the rest of the install. Since  I had been 
running without problems on 7.1 for a while I didn't even notice the test the 
keyboard box at the bottom of the second screen.  I just took the default and 
moved on. I actually upgraded from 7.1 to 7.2, I guess it's correct to call that an 
install. At any rate the system seems to work fine so far, the serial keyboard 
works just fine.
Comment 5 Brent Fox 2001-11-08 11:09:16 EST
Oh, an upgrade.  I was thinking that you would at least have to use the keyboard
to enter a root password, but not during an upgrade.

But the USB keyboard still doesn't work?  I'm not sure how to progress on this
report because all the USB keyboards we have here work.  I can't get a
reproducible test case.
Comment 6 joels 2001-11-08 23:34:18 EST
BUMMER....want mine?
Comment 7 Brent Fox 2001-11-08 23:44:17 EST
Well, I wonder if it is a problem with the keyboard itself or with our detection
of USB devices on the Presario 7000.  I'm thinking that the problem is probably
not with the keyboard itself.

So does the keyboard work after the upgrade?
Comment 8 joels 2001-11-09 00:14:17 EST
it's a long story but I have two hard drives in the machine. One for windows the 
other for linux. I don't use LILO or GRUB I boot Linux from diskette. The default 
boot is to windows. When using windows the USB keyboard works fine.  I found a 
lot of what appears good info in a file in the var/log directory, its called dmesg. 
Want it?
Comment 9 Brent Fox 2001-11-09 15:46:13 EST
Yes, please.
Comment 10 Brent Fox 2001-11-19 14:46:01 EST
Any more info here?
Comment 11 joels 2001-11-20 21:56:26 EST
did you not get the dmesg tar file?
Comment 12 Brent Fox 2001-12-19 10:03:39 EST
No, can you attach it to the bug report?
Comment 13 Bernard So Kua 2001-12-24 10:52:32 EST
Created attachment 41290 [details]
usbview output
Comment 14 Bernard So Kua 2001-12-24 10:54:57 EST
Got the usbview output from service request 193828. I hope that helps.
Comment 15 Brent Fox 2002-01-07 11:36:34 EST
It appears that the kernel isn't seeing the USB keyboard.  I'm going to change
the component of this bug report to the kernel.
Comment 16 Pete Zaitcev 2002-01-07 12:19:43 EST
This is a dup of Bug 55878, but DON'T DUP just yet.

I am pulling my hair by the fistful over this.

Is there a way to get that keyboard in Meridian
attached to a remotely accessible box?
Comment 17 Brent Fox 2002-01-11 12:55:13 EST
bkua, do you have that keyboard in Meridian?  I have a few USB keyboards, but
none of them have this behavior.
Comment 18 Pete Zaitcev 2002-01-11 13:15:05 EST
Yes, this is the problem: it must be the exact model and
microcode revision. The other guy had it fail with a
particular version of HP USB keyboard, which is not produced
anymore. The spare for his model availabe from HP works fine.
Comment 19 Bernard So Kua 2002-01-14 07:35:50 EST
Sorry bfox, I am just a tech. support here. Jsweatte is the direct contact for
this. I am just relaying his posts on the ticket manager.

Note You need to log in before you can comment on or make changes to this bug.