Bug 55681 - loading of scsi module fails at boot time
Summary: loading of scsi module fails at boot time
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu   
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-04 20:35 UTC by adler
Modified: 2014-03-17 02:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-12 20:46:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modules.conf config file for problemed system (300 bytes, text/plain)
2001-11-04 20:41 UTC, adler
no flags Details

Description adler 2001-11-04 20:35:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
The following message appears on the console, "improperly terminated string
argument for ncr53c8xx", and the kernel halts its booting process.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Have a system with a scsi controler which needs the ncr53c8xx driver
2.upgrade this system from 6.2 to 7.2
3.watch the boot fail...
	

Additional info:

I believe the bug is due to the fact that under Red Hat 6.2, the
/etc/modules.conf file has an options entry for the ncr53c8xx.o module.
When I commented out this options entry, re-ran the mkinitrd for the kernel
I boot, then I was able to boot up fine.

Comment 1 adler 2001-11-04 20:41:54 UTC
Created attachment 36361 [details]
modules.conf config file for problemed system

Comment 2 adler 2001-11-04 20:44:06 UTC
I've attached the /etc/modules.conf file. Notice that I've commented out the
options entry for the ncr53c8xx.o module. This is what I needed to do in order
to get the kernel to boot properly (2.4.9-13smp) after doing an mkinitrd. Also,
I had the same problem with kernels 2.4.7-10smp.

Comment 3 Arjan van de Ven 2001-11-21 15:49:06 UTC
This is more an upgrade bug; such module options shouldn't be kept during major
kernel upgrades (from 2.2 to 2.4)

Comment 4 Jeremy Katz 2001-12-12 20:46:32 UTC
Anaconda doesn't really mess with this...  reassigning to kudzu

Comment 5 Bill Nottingham 2001-12-13 17:52:49 UTC
kudzu doesn't really have an infrastructure to keep track of what options are
good vs. bad for what particular module in what particular kernel version. I'm
not sure there's really any way to fix this unilaterally.


Note You need to log in before you can comment on or make changes to this bug.