Bug 55688 - device alias selector doesn't stay sensitive
Summary: device alias selector doesn't stay sensitive
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network   
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-04 23:20 UTC by Dan Moore
Modified: 2008-05-01 15:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-05 16:04:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch that fixes both 'ethernetconfig.py' and 'tokenringconfig.py' (1.15 KB, patch)
2001-11-04 23:25 UTC, Dan Moore
no flags Details | Diff

Description Dan Moore 2001-11-04 23:20:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
1.  start up
1.  in Network Configuration window
2.  go to Devices tab
3.  either Add a device or Edit an existing one

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  start up 'Network Configuration'
2.  in 'Network Configuration' window go to 'Devices' tab
3.  either 'Add' a device or 'Edit' an existing device
4.  in 'Ethernet Device' window go to 'Hardware Device' tab
5.  if 'Enable Device Alias support' is checked, go to step 11
6.  notice that the 'Alias' selector is sensitive (able to be changed)
7.  click 'OK'
8.  go back to 'Devices' tab on 'Network Configuration' window
9.  'Edit' whichever device you added or edited in step 3
10. go to 'Hardware Device' tab of 'Ethernet Device' window11.  notice that
the 'Alias' selector is not sensitive (able to be changed)

Actual Results:  notice that the 'Alias' selector is not sensitive (able to
be changed), despite the fact that the 'Enable Device Alias support'
checkbox is still checked

Expected Results:  the 'Alias' selector should still be sensitive (able to
be changed)

Additional info:

the bug is in netconfpkg/ethernetconfig.py that i noticed...
tokenringconfig.py has the same problem though.  i'll attach a patch which
fixes both.

Comment 1 Dan Moore 2001-11-04 23:25:30 UTC
Created attachment 36402 [details]
patch that fixes both 'ethernetconfig.py' and 'tokenringconfig.py'

Comment 2 Harald Hoyer 2001-11-05 16:04:32 UTC
fixed since 0.9.6


Comment 3 Jay Turner 2002-08-14 18:50:35 UTC
Fix confirmed in the current tree.


Note You need to log in before you can comment on or make changes to this bug.