Bug 55698 - floating point in ecos on i386 system
floating point in ecos on i386 system
Status: CLOSED WONTFIX
Product: eCos
Classification: Retired
Component: ecosconfig (Show other bugs)
CVS
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Julian Smart
Julian Smart
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-05 03:04 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-20 12:04:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-05 03:04:39 EST
Description of Problem:
I have a problem using floats in a ecos prg. see the prg.
I use a downloaded floppy image to boot the pc. If i config my tree, where 
i build the samples against, with the following lines i have the problem:
ecosconfig pc
ecosconfig tree 
make

if i manualy disable the CYGHWR_HAL_I386_FPU_SWITCH_LAZY (user_value 0) 
the program works fine. 


int main(void)
{

char s[100];
float f;//=0.0123;

strcpy (s,"Rini van Zetten");

f=0.2;
printf("Hello, eCos world!, f= %f\n",f);

return 0;
}

before the line f=0.2; the value of s is of course "Rini van Zetten" but 
after that line the first 4 chars are changed.
Also if i comment out the char part the program crashes on the printf 
statement.


Version-Release number of selected component (if applicable):
dowloaded from cvs last week of october

How Reproducible:

see description

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:

see description

Expected Results:


see description

Additional Information:
	
the problem is solved but in the email list Jonathan Larmour asked me to 
report it as a bug.
Comment 1 Alex Schuilenburg 2003-06-20 12:04:14 EDT
This bug has moved to http://bugs.ecos.sourceware.org/show_bug.cgi?id=55698

Note You need to log in before you can comment on or make changes to this bug.