Bug 557039 - guest boot with "-usbdevice tablet" not accepting mouse clicking after resume from suspend to mem
guest boot with "-usbdevice tablet" not accepting mouse clicking after resume...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5
All Linux
medium Severity high
: rc
: ---
Assigned To: Markus Armbruster
Virtualization Bugs
: Triaged
Depends On:
Blocks: Rhel5KvmTier2 736012
  Show dependency treegraph
 
Reported: 2010-01-20 03:19 EST by Suqin Huang
Modified: 2013-01-09 17:13 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 736012 (view as bug list)
Environment:
Last Closed: 2011-09-06 07:40:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suqin Huang 2010-01-20 03:19:04 EST
Description of problem:
rhel5 guest which boot with "-usbdevice tablet" not accepting mouse clicking after resume from suspend to mem

Version-Release number of selected component (if applicable):
kvm-83-147.el5

How reproducible:
always

Steps to Reproduce:
1. boot guest (guest installed with if=ide)
CLI:  
/usr/libexec/qemu-kvm  -smp 2 -m 2G -drive file=/root/rhel5.4-32.raw,media=disk,if=ide,cache=off,index=0,serial=fb-bde1-8b6f10f72b98 -net nic,vlan=0,macaddr=00:55:86:01:00:37,model=e1000 -net tap,vlan=0,script=/etc/qemu-ifup -uuid `uuidgen` -no-hpet -usbdevice tablet  -rtc-td-hack  -startdate now -cpu qemu64,+sse2  -monitor stdio -vnc :5

2. echo mem > /sys/power/state
3.
  
Actual results:
guest work normally except mouse clicking after resume, such as ping network, edit files.

Expected results:


Additional info:
1. mouse work normally after resume if boot without "-usbdevice tablet"

2. xorg.conf
Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0"
	InputDevice    "Mouse0" "CorePointer"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "evdev"
	Option	    "Name" "QEMU 0.8.2 QEMU USB Tablet" 
	Option	    "Device" "/dev/input/event2"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "void"
	Option	    "Device" "/dev/input/event1"
EndSection

3. guest
2.6.18-164.11.1.el5
i386 & x86_64

4. kvm
[root@s145 ~]# uname -r
2.6.18-183.el5

[root@s145 ~]# rpm -qa | grep kvm
kvm-tools-83-147.el5
kvm-83-147.el5
kvm-debuginfo-83-147.el5
etherboot-zroms-kvm-5.4.4-13.el5
kvm-qemu-img-83-147.el5
etherboot-roms-kvm-5.4.4-13.el5
kmod-kvm-83-147.el5

5. host
processor	: 7
vendor_id	: GenuineIntel
cpu family	: 6
model		: 26
model name	: Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
Comment 1 Keqin Hong 2010-01-22 07:49:51 EST
The same problem occurred after migration.
Note: only occurred on 32bit RHEL5.4.

CLI:
/usr/libexec/qemu-kvm -m 8G -smp 8 -drive file=RHEL-Server-5.4-32-virtio.qcow2,if=ide,cache=off,boot=on -net nic,model=e1000,vlan=1,macaddr=DE:AD:BE:EF:17:19 -net tap,vlan=1,script=/etc/qemu-ifup -usbdevice tablet -no-hpet -rtc-td-hack -no-kvm-pit-reinjection -monitor stdio -notify all -cpu qemu64,+sse2 -balloon none -vnc :1

[guest info]:
2.6.18-164.11.1.el5PAE

[host info]:
kvm-83-148.el5

8 cores
...
processor	: 7
vendor_id	: GenuineIntel
cpu family	: 6
model		: 26
model name	: Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
stepping	: 4
cpu MHz		: 2668.000
cache size	: 8192 KB
physical id	: 0
siblings	: 8
core id		: 3
cpu cores	: 4
apicid		: 7
fpu		: yes
fpu_exception	: yes
cpuid level	: 11
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx rdtscp lm constant_tsc ida nonstop_tsc pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr sse4_1 sse4_2 popcnt lahf_lm
bogomips	: 5319.91
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management: [8]
Comment 4 RHEL Product and Program Management 2011-01-11 15:52:38 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2011-01-11 17:48:54 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 7 Markus Armbruster 2011-08-09 05:52:42 EDT
Can this bug still be reproduced?

Does it bite RHEL-6 as well?
Comment 8 Golita Yue 2011-08-17 06:17:18 EDT
Cannot reproduce this bug in rhel5.7 host.

host information:
kernel-2.6.18-274.el5
kvm-83-239.el5

guest information:
kernel-2.6.18-194.el5

steps:
1. boot up vm with -usbdevice tablet
2. echo mem > /sys/power/state
3. when vm resume from s3, click the mouse inside guest to open some tab or applications.

after step3, the mouse works normally.

cmd:
/usr/libexec/qemu-kvm  -smp 2 -m 2G -drive file=rhel5.5-32.raw,media=disk,if=ide,cache=off,index=0,serial=fb-bde1-8b6f10f72b98 -net nic,vlan=0,macaddr=00:55:86:01:00:37,model=e1000 -net tap,vlan=0,script=/etc/qemu-ifup-switch -uuid `uuidgen` -no-hpet -usbdevice tablet -rtc-td-hack  -startdate now -cpu qemu64,+sse2  -monitor stdio -vnc :5 -boot c
Comment 9 Golita Yue 2011-08-17 06:39:37 EDT
Tried comment #1 steps again, didn't reproduce this bug too.

steps:
1. boot up vm with -usbdevice tablet
2. do migration

after step2, the mouse works normally.

cmd:
/usr/libexec/qemu-kvm  -smp 8 -m 8G -drive file=rhel5.5-32.raw,media=disk,if=ide,cache=off,index=0,serial=fb-bde1-8b6f10f72b98 -net nic,vlan=0,macaddr=00:55:86:01:00:37,model=e1000 -net tap,vlan=0,script=/etc/qemu-ifup-switch -uuid `uuidgen` -no-hpet -usbdevice tablet -rtc-td-hack  -startdate now -cpu qemu64,+sse2  -monitor stdio -vnc :5 -boot c
Comment 10 Suqin Huang 2011-08-17 23:22:51 EDT
can you set xorg.conf as comment0 and retest again, also try migration and provide guest info.
Comment 11 Suqin Huang 2011-08-18 06:26:53 EDT
I can reproduce it with 2.6.18-194.el5 guest

1). cfg xorg.conf as comment0
2). #echo mem > /sys/power/state

host:
2.6.18-274.el5
kvm-83-239.el5

processor	: 7
vendor_id	: GenuineIntel
cpu family	: 6
model		: 26
model name	: Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
stepping	: 4
cpu MHz		: 1600.000
cache size	: 8192 KB

flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx rdtscp lm constant_tsc ida nonstop_tsc pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr sse4_1 sse4_2 popcnt lahf_lm
bogomips	: 5415.71
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual

cmd: 

/usr/libexec/qemu-kvm -smp 8 -m 8G -drive file=rhel5.5-32.raw,media=disk,if=ide,cache=off,index=0,serial=fb-bde1-8b6f10f72b98 -net nic,vlan=0,macaddr=00:55:86:01:00:37,model=e1000 -net tap,vlan=0,script=/etc/qemu-ifup-switch -uuid e9cac2ae-b76c-4e9d-af78-fe8ace807ff0 -usbdevice tablet -rtc-td-hack -startdate now -cpu qemu64,+sse2 -monitor stdio -vnc :5

Note You need to log in before you can comment on or make changes to this bug.