Bug 557082 - Menu item translations go missing intermittently in different gnome-packagekit builds
Summary: Menu item translations go missing intermittently in different gnome-packageki...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-packagekit
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-20 11:11 UTC by Ville-Pekka Vainio
Modified: 2010-12-04 00:06 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-04 00:06:02 UTC
Type: ---


Attachments (Terms of Use)

Description Ville-Pekka Vainio 2010-01-20 11:11:20 UTC
Description of problem:
I'm using gnome-packagekit in Finnish. It seems like the menu item translations appear in one build and go missing again in another. Right now the following .desktop files have no translations at all:

gpk-application.desktop
gpk-log.desktop
gpk-prefs.desktop

I know it may be difficult to trace what's happening in builds where .desktop translations go missing, but in my opinion this is an important thing to get fixed.

Version-Release number of selected component (if applicable):
gnome-packagekit-2.28.3-0.1.20091211git.fc12.i686

How reproducible:
Sometimes ??

Steps to Reproduce:
1. Build gnome-packagekit
  
Actual results:
Some .desktop files are completely missing translations

Expected results:
All .desktop files should include the translations provided in .po files.

Comment 1 Ville-Pekka Vainio 2010-01-26 11:09:27 UTC
This problem seems to be either arch-specific or then it just really happens randomly on different builds. In x86_64 the only .desktop file missing translations is gpk-log.desktop.

Comment 2 Ville-Pekka Vainio 2010-01-26 12:07:47 UTC
I tested this with mock on my local system, x86_64 had translations in all .desktop files, i686 had one .desktop file with no translations.

Comment 3 Ville-Pekka Vainio 2010-02-02 09:26:39 UTC
On Fedora 13 x86_64 all menu items are translated as of yesterday's Rawhide. Either it's just good luck that everything worked or something has been fixed between F12 and F13.

Comment 4 Ville-Pekka Vainio 2010-02-22 20:49:26 UTC
Just making a note that this is not fixed in F13, the new gpk packages still have some .desktop file translations missing.

Comment 5 Ville-Pekka Vainio 2010-02-23 07:04:12 UTC
I asked about this on the devel list, Kevin Kofler suggested disabling parallel build: http://lists.fedoraproject.org/pipermail/devel/2010-February/131186.html

Richard, could you try building gnome-packagekit without %{?_smp_mflags} at least for a while? I can of course do some tests with mock locally, but doing multiple builds and checking the .desktop files is quite tedious (or would involve writing scripts to do that...)

Comment 6 Ville-Pekka Vainio 2010-03-01 20:15:09 UTC
(In reply to comment #5)
> Richard, could you try building gnome-packagekit without %{?_smp_mflags} at
> least for a while?

Ping?

Comment 7 Igor Pires Soares 2010-03-04 17:52:34 UTC
I can confirm gnome-packagekit-2.28.3-0.1.20091211git.fc12.i686 has missing .desktop translations, but everything is ok on x86_84 build.

Comment 8 Ville-Pekka Vainio 2010-03-09 22:09:04 UTC
It seems like the newest gpk build for F13, gnome-packagekit-2.29.91-3.fc13, has translations in all .desktop file in both x86_64 and i686. Let's keep this bug open for a while and see if it was just good luck again...

Comment 9 Ville-Pekka Vainio 2010-04-16 16:23:49 UTC
gnome-packagekit-2.30.0-2.fc13.i686 seems to be missing the translation for the 'Software Updates' menu item. I hope Richard has the time to test a few builds without smp_mflags soon.

Comment 10 Richard Hughes 2010-07-13 10:41:19 UTC
I've been told the newest docbook-utils fixes this properly.

Comment 11 Ville-Pekka Vainio 2010-08-31 10:30:07 UTC
I'm reopening this: It's now the time for translator to review translations for Fedora 14 and I noticed "Add/Remove Software" and "Software Updates" are not translated in F14 Alpha + updates.

This is gnome-packagekit-2.31.6-2.fc14.x86_64. In /usr/share/applications/gpk-application.dektop and gpk-prefs.desktop there are no translations at all.

Comment 12 Ville-Pekka Vainio 2010-08-31 10:42:14 UTC
I tried building the 2.32 branch of gnome-packagekit from git locally on F13. Without a -j switch to make it seems like the menu item translations are generated correctly. If I add a -j 3 switch to make, there's always a problem of some sort with the translations.

Comment 13 Bug Zapper 2010-11-04 00:26:21 UTC
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 14 Bug Zapper 2010-12-04 00:06:02 UTC
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.