Bug 55715 - multiple autofs mounts
multiple autofs mounts
Status: CLOSED DUPLICATE of bug 65003
Product: Red Hat Linux
Classification: Retired
Component: autofs (Show other bugs)
7.2
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-05 11:07 EST by adler
Modified: 2007-03-26 23:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-26 07:50:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adler 2001-11-05 11:07:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
autofs is mounting the same file system twice. Check out the following df
for an example.

[ofer@g2pro2 2000-137]$ df
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/sda1              1983964   1673132    208420  89% /
none                    256228         0    256228   0% /dev/shm
/dev/sda3              6496640   4924064   1237220  80% /home
/dev/sdb1             17063007  14790058   1384320  92% /local.dsk/g2prod2
physgi00:/users/usr0  97684664  82132896  15551768  85% /users/usr0
/local.dsk/g2prod2    17063007  14790058   1384320  92% /phyppro/g2prod2
phyppro2:/local.dsk/g2disk1
                      21702268  20355421    213865  99% /phyppro/g2disk1
physgi00:/users/usr0  97684664  82132896  15551768  85% /users/usr0
phyppro2:/local.dsk/g2disk1
                      21702268  20355421    213865  99% /phyppro/g2disk1
/local.dsk/g2prod2    17063007  14790058   1384320  92% /phyppro/g2prod2




Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.load redhat 7.2
2.configure automount
3.what automout mount same mount point twice
	

Additional info:
Comment 1 Ofer Rind 2001-11-05 19:55:26 EST
The relevant parts of the autofs configuration files on this system are as follows:

auto.master:
/phyppro        /etc/auto.phyppro       --timeout 60
/users          /etc/auto.users         --timeout 60

auto.phyppro:
g2disk1 -nosuid,nodev,hard,intr,rw,rsize=8192,wsize=8192 phyppro2:/local.dsk/g2disk1
g2prod2 -nosuid,nodev,hard,intr,rw,rsize=8192,wsize=8192 g2pro2:/local.dsk/g2prod2

auto.users:
usr0    -nosuid,nodev,intr,rw,rsize=8192,wsize=8192 physgi00:/users/usr0

and the mount command returns the following information (at a later stage now
wherein the number of multiple mounts has increased):

# mount
/dev/sda1 on / type ext3 (rw)
proc on /proc type proc (rw)
none on /dev/shm type tmpfs (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/sda3 on /home type ext3 (rw,nosuid,usrquota)
/dev/sdb1 on /local.dsk/g2prod2 type ext3 (rw)
automount(pid754) on /phyppro type autofs (rw,fd=5,pgrp=754,minproto=2,maxproto=3)
automount(pid815) on /users type autofs (rw,fd=5,pgrp=815,minproto=2,maxproto=3)
physgi00:/users/usr0 on /users/usr0 type nfs
(rw,nosuid,nodev,intr,rsize=8192,wsize=8192,addr=130.199.22.67)
/local.dsk/g2prod2 on /phyppro/g2prod2 type none (rw,bind)
phyppro2:/local.dsk/g2disk1 on /phyppro/g2disk1 type nfs
(rw,nosuid,nodev,hard,intr,rsize=8192,wsize=8192,addr=130.199.22.10)
automount(pid2153) on /phyppro type autofs (rw,fd=5,pgrp=2153,minproto=2,maxproto=3)
automount(pid2231) on /users type autofs (rw,fd=5,pgrp=2231,minproto=2,maxproto=3)
physgi00:/users/usr0 on /users/usr0 type nfs
(rw,nosuid,nodev,intr,rsize=8192,wsize=8192,addr=130.199.22.67)
phyppro2:/local.dsk/g2disk1 on /phyppro/g2disk1 type nfs
(rw,nosuid,nodev,hard,intr,rsize=8192,wsize=8192,addr=130.199.22.10)
/local.dsk/g2prod2 on /phyppro/g2prod2 type none (rw,bind)
automount(pid21046) on /phydsk type autofs
(rw,fd=5,pgrp=21046,minproto=2,maxproto=3)
automount(pid21068) on /phyppro type autofs
(rw,fd=5,pgrp=21068,minproto=2,maxproto=3)
automount(pid21097) on /physgi type autofs
(rw,fd=5,pgrp=21097,minproto=2,maxproto=3)
automount(pid21124) on /amd.aux type autofs
(rw,fd=5,pgrp=21124,minproto=2,maxproto=3)
automount(pid21148) on /users type autofs (rw,fd=5,pgrp=21148,minproto=2,maxproto=3)
phyppro2:/local.dsk/g2disk1 on /phyppro/g2disk1 type nfs
(rw,nosuid,nodev,hard,intr,rsize=8192,wsize=8192,addr=130.199.22.10)
/local.dsk/g2prod2 on /phyppro/g2prod2 type none (rw,bind)
physgi00:/users/usr0 on /users/usr0 type nfs
(rw,nosuid,nodev,intr,rsize=8192,wsize=8192,addr=130.199.22.67)
Comment 2 Harald Hoyer 2002-03-26 07:50:52 EST
Same problem, have the same directory mounted 24 times now after one day.

$ mount|fgrep porky|wc -l
     24
[harald@faro harald]$ mount|fgrep porky|sort -u
porky.stuttgart.redhat.com:/mnt/raid on /mnt/raid type nfs
(ro,rsize=8192,wsize=8192,nolock,soft,intr,bg,addr=172.16.2.140)
Comment 3 James Manning 2002-05-26 12:59:00 EDT
yeah, autofs has to better-handle existing mounts in its fs-space or we need a
mechanism to selectively disable the "supermounting" feature - since the latter
is unlikely, it will (not that it should) fall back to autofs to perform a check
on the would-be mountpoint to make sure it's not already the target of an
existing mount (a stat just checking to see if it exists, perhaps) before it
attempts the mount.

Until it does so, it'll keep happily remounting the same existing mount ad
infinitum.

*** This bug has been marked as a duplicate of 65003 ***
Comment 4 David van Leeuwen 2004-04-16 05:58:58 EDT
On my systems the number of multiple mount becomes scarily 
large. 

Has the problem ever been fixed?

 

Note You need to log in before you can comment on or make changes to this bug.