Bug 557323 - UnboundLocalError: local variable 'name' referenced before assignment
Summary: UnboundLocalError: local variable 'name' referenced before assignment
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 557571 (view as bug list)
Depends On:
Blocks: F13Alpha, F13AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2010-01-21 01:50 UTC by Jesse Keating
Modified: 2013-01-10 03:31 UTC (History)
5 users (show)

Fixed In Version: anaconda-13.22-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-05 17:11:43 UTC


Attachments (Terms of Use)
crash file from anaconda (73.02 KB, application/octet-stream)
2010-01-21 01:50 UTC, Jesse Keating
no flags Details

Description Jesse Keating 2010-01-21 01:50:25 UTC
Created attachment 385826 [details]
crash file from anaconda

anaconda 13.21 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/filter_gui.py", line 604, in populate
    tuple = (data, True, _active(name), rs.name, partedDevice.model,
  File "/usr/lib/anaconda/iw/filter_gui.py", line 523, in getScreen
    self.populate(nonraids, mpaths, raids)
  File "/usr/lib/anaconda/gui.py", line 1361, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib/anaconda/gui.py", line 1282, in nextClicked
    self.setScreen ()
UnboundLocalError: local variable 'name' referenced before assignment

I got this when attempting an install with a fresh dmraid set, not sure if that has much to do with it.  Probably this was the screen to initialize the disks.

Comment 1 Chris Lumens 2010-01-21 20:56:19 UTC
*** Bug 557571 has been marked as a duplicate of this bug. ***

Comment 2 Adam Williamson 2010-02-05 17:11:43 UTC
jlaska says he hasn't seen this lately, and anaconda team agree it's likely fixed in a rewrite of the code. closing, re-open if it reoccurs.


Note You need to log in before you can comment on or make changes to this bug.