Bug 557336 - Chinese PDfs not generating due to use of TrueType font collections
Chinese PDfs not generating due to use of TrueType font collections
Status: CLOSED ERRATA
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
: 509044 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-20 22:00 EST by Jeff Fearn
Modified: 2010-11-23 23:17 EST (History)
6 users (show)

See Also:
Fixed In Version: 1.4-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-31 20:15:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Fearn 2010-01-20 22:00:59 EST
Description of problem:
The Chinese fonts are packaged as TrueType font collections and the automated routine FOP uses can not use ttc fonts.

Version-Release number of selected component (if applicable):
1.3

How reproducible:
Always

Steps to Reproduce:
1. Create a chines translation of a book
2. build Chinese PDF

  
Actual results:
Chinese characters are missing from the generated PDF.

Expected results:
Chinese characters visible in the PDF.

Additional info:
The common content is translated so this is visible even on books with no translation.

It should be possible to use the XML metrics approach used in publican 0.4x but only generate metrics for TTC fonts and leave normal TTF fonts to be generated via the auto-detect routine.
Comment 1 Jeff Fearn 2010-01-24 16:47:01 EST
Added script to generate metrics for known TTC fonts at build time.
Comment 2 Fedora Update System 2010-01-28 21:05:58 EST
publican-1.4-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-1.4-1.fc12
Comment 3 Fedora Update System 2010-01-28 21:07:12 EST
publican-1.4-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/publican-1.4-1.fc11
Comment 4 Fedora Update System 2010-01-31 20:14:04 EST
publican-1.4-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2010-01-31 20:22:24 EST
publican-1.4-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Jens Petersen 2010-05-20 02:31:19 EDT
*** Bug 509044 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.