Bug 557369 - gnote: impossible to disable add-ins
Summary: gnote: impossible to disable add-ins
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnote
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Rahul Sundaram
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 572241 648417 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-21 08:06 UTC by Jan Dvořák
Modified: 2010-11-19 00:12 UTC (History)
7 users (show)

Fixed In Version: gnote-0.7.3-2.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-08 22:39:24 UTC
Type: ---


Attachments (Terms of Use)
backported fix (19.33 KB, patch)
2010-11-01 10:05 UTC, Dan Horák
no flags Details | Diff
F-14 build fix (740 bytes, patch)
2010-11-01 10:05 UTC, Dan Horák
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 615865 None None None Never

Description Jan Dvořák 2010-01-21 08:06:59 UTC
Description of problem:

It is impossible to permanently disable a gnote add-in.

Version-Release number of selected component (if applicable):

gnote-0.7.1-1.fc13.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. Add gnote applet to a panel.
2. Left-click on the applet, select today's note, delete it.
3. Right-click on the applet, select Preferences->Add-ins->Note of the Day->Disable. Close Preferences.
4. Right-click on the applet and remove and re-add it to the panel. Or kill it. Or log out and log back in.
5. Left-click on the gnote applet and observe today's note.
6. Check out add-ins, they are all enabled.
  
Actual results:

Add-ins always revert to enabled.

Expected results:

Disabled add-ins actually remain disabled.

Additional info:

Comment 1 Rahul Sundaram 2010-02-11 06:18:46 UTC
This is a known upstream issue and Rishi is working on it

http://mail.gnome.org/archives/gnote-list/2010-January/msg00009.html

Comment 2 Rahul Sundaram 2010-03-10 18:06:19 UTC
*** Bug 572241 has been marked as a duplicate of this bug. ***

Comment 3 Bug Zapper 2010-03-15 14:09:35 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Scott Schmit 2010-06-04 04:35:16 UTC
I can't add this to the metadata, since I didn't report this, but this is GNOME Bug #615865. Unfortunately, it's been open as "unconfirmed" since April, so obviously there has been absolutely no action on this.

Comment 5 Rahul Sundaram 2010-06-04 04:38:20 UTC
The upstream developer is pretty busy and so am I but I will gladly take patches.

Comment 6 Rahul Sundaram 2010-11-01 09:42:45 UTC
*** Bug 648417 has been marked as a duplicate of this bug. ***

Comment 7 Dan Horák 2010-11-01 10:05:08 UTC
Created attachment 456833 [details]
backported fix

Comment 8 Dan Horák 2010-11-01 10:05:36 UTC
Created attachment 456834 [details]
F-14 build fix

Comment 9 Rahul Sundaram 2010-11-01 11:21:47 UTC
Thanks for this.  There are a number of minor bugs that have been fixed in HEAD and I am awaiting a new bug fix release from upstream shortly.

http://mail.gnome.org/archives/gnote-list/2010-October/msg00015.html

Once a release is done, I will push out a update for Fedora 14 and 13.  I don't want to cherry pick one bug fix after another at this point.

Comment 10 Debarshi Ray 2010-11-05 02:13:53 UTC
Gnote 0.7.3 has been released. :-)

Comment 11 Fedora Update System 2010-11-06 00:12:55 UTC
gnote-0.7.3-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gnote-0.7.3-2.fc14

Comment 12 Fedora Update System 2010-11-06 00:28:11 UTC
gnote-0.7.3-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/gnote-0.7.3-2.fc13

Comment 13 Fedora Update System 2010-11-06 23:40:49 UTC
gnote-0.7.3-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnote'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/gnote-0.7.3-2.fc13

Comment 14 Fedora Update System 2010-11-08 22:39:15 UTC
gnote-0.7.3-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2010-11-19 00:12:15 UTC
gnote-0.7.3-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.