Bug 55743 - Kernel Panic with Megaraid SCSI RAID Controller
Kernel Panic with Megaraid SCSI RAID Controller
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-05 17:17 EST by Erik Timmermann
Modified: 2007-04-18 12:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-18 13:22:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik Timmermann 2001-11-05 17:17:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
I get this message when the server is booting up:

Creating root device
Mounting root filesystem
mount:  error 6 mounting ext2
pivotroot: pivot_root(/sysroot,sysroot/initrd) failed: 2
Freeing unused kernel memory: 240k freed
Kernel panic:  No init found.  Try passing init= option to kernel.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Redhat 7.2 with MegaRAID controller installed.
2.Reboot.
3.The error occurs.
	

Actual Results:  The system has a Kernel Panic.

Expected Results:  I expect it to boot.

Additional info:

The computer is a Pentium III 1.0 GHz Dual Prossessor system with 2 GB of 
RAM, MegaRAID controller and onboard Symbios SCSI controller.

The error message again is:
Creating root device
Mounting root filesystem
mount:  error 6 mounting ext2
pivotroot: pivot_root(/sysroot,sysroot/initrd) failed: 2
Freeing unused kernel memory: 240k freed
Kernel panic:  No init found.  Try passing init= option to kernel.

When I reomove the MEGARAID card the computer boots properly.

With the MEGARAID card installed I can boot with the Install CD-ROM in 
rescue mode and it works, the megaraid.o module is loaded and I can access 
the RAID.  It just panics durning a "normal" boot.  I have recomplied the 
kernel and modules but the problem did was still there.
Comment 1 Arjan van de Ven 2001-11-05 17:33:47 EST
Did you accidentially remove the /initrd directory ? That directory must exist!
(since you can boot in rescue mode you can manually recreate it)
Comment 2 Erik Timmermann 2001-11-05 18:42:14 EST
When I boot into rescue mode the root of that has no initrd.  But the directory 
of /mnt/sysimage has an initrd that is empty.  So, I just created the directory 
on / (before ever running chroot /mnt/sysimage) and am rebooting . . . . . . 
nope the problem is still there and I am 100% sure that the /initrd directory 
is there.
Comment 3 Erik Timmermann 2001-11-08 13:31:50 EST
Here is some new info:

I pulled out the RAID controller and installed RedHat 7.2, the system boots 
fine without the controller installed.  I put the controller back and kudzu 
finds it and configures the card.  The module for megaraid does not load, even 
after I reboot the system.  I can load it by hand and mount the RAID after 
that, but that is not the way it should work.

Another test I did was to hook up all the disks in the box to the megaraid 
controller, that works fine but kills our redundancy.  It may be the 
combination of the Symbios and Megaraid controllers that is causing problems.

Comment 4 Arjan van de Ven 2001-11-08 13:42:39 EST
And /etc/modules.conf does show the megaraid card ?
If so, you might need to recreate the initrd that is used to boot from.
(Or just install a new kernel, say the errata kernel, and the new initrd will
have the megaraid driver by default)
Comment 5 Erik Timmermann 2001-11-09 12:05:55 EST
That worked, but there are some interesting notes to the whole event.

If I installed the new kernel (kernel-smp-2.4.9-13.i686.rpm) on the system that 
had kernel panics the results stayed the same, kernel panic.  

I then went to an identical system that I had removed the Megaraid card before 
installation.  Then I installed the Megaraid card and used kudzu to configure 
they system.  During the boot with the old kernel it would go ok, but it would 
not load the Megaraid driver.  I then install the new kernel (kernel-smp-2.4.9-
13.i686.rpm) it works perfectly.  Problem solved.  I repeated this process on 
the system with the problem and it worked there too.

I am wondering if the original initrd image may have a problem?  I am guessing 
installing the kernel-smp-2.4.9-13.i686.rpm rebuilds the initrd image with info 
from the previous initrd.
Comment 6 Anthony Rumble 2002-01-16 02:24:23 EST
We have had much the same bug ourselves.. 
However, I think this user has showed you the effect of 
the error
and not the cause. If he showed about 10 more lines above
that error (before), he 
would have seen this..

megaraid.o: No Bios Found

This is what we had when we tried to boot the 
2.4.9-13 kernels.
2.4.7-10 however, works fine. We have had to back this site
to 2.4.7 because 
of this.

Another thing to note, when we built the kernel from kernel-source-2.4.7-10
using the 
same config/config.... we get the same problem as with 
the 2.4.9-13 kernel.

Could this be a 
compiler bug? or some wierd binary offset problem?

Anthony
Comment 7 Philip Rhoades 2002-01-17 18:37:08 EST
Anthony's comment was about our machine.  A bit more info that may be useful - this particuar 
machine had previously had RH6.1 and later 7.1 installed on it.  In both cases I had quite happily 
built new SMP kernels so something fundamental has changed from 7.1 to 7.2 .  Maybe it is not in the 
actual megaraid.c file but there is something tragic going on . .
Comment 8 Arjan van de Ven 2002-01-18 13:22:06 EST
This REALLY starts to smell like a mkinitrd bug; I'm assigning it to that
package for now
Comment 9 Erik Troan 2002-05-21 17:27:45 EDT
Unfortunately, there is no way to test this hypothesis, but...

I'd guess that the order of the scsi controllers in /etc/modules.conf was
horked, so the modules got installed in the wrong order. This would prevent the
initrd from finding the "right" root filesystem. Rerunning kudzu after
reinstalling the card (as described) and the regenerating the initrd would fix
this. This could still be an initrd or an anaconda bug; probably not a kernel bug.

The kernel panic and "bios not found" items *are* kernel bugs. If you're still
seeing those, they should be opened as separate bugs.

I'm closing this as WORKSFORME. If you're still having these problems, please
reopen the bug so we can try and isolate it.
Comment 10 David Weingart 2003-04-23 09:40:35 EDT
I'm having precisely the same kernel panic, with recent RedHat 7.3 kernels. 

The original kernel installed with 7.3 (2.4.18-3smp) works fine, but all of the
subsequent errata kernels I've tried give the same "Kernel Panic: No Init Found"
error as mentioned in this bug report.

The hardware is a dual processor Dell PowerEdge 4300, with a PowerEdge
Expandable RAID Controller.

Error messages are exactly as decribed above:

"Megaraid: No BIOS Installed"
"Kernel panic:  No init found.  Try passing init= option to kernel."

etc.



Note You need to log in before you can comment on or make changes to this bug.