Bug 557434 - UnicodeEncodeError with LANG=de_DE.utf-8
UnicodeEncodeError with LANG=de_DE.utf-8
Status: CLOSED DUPLICATE of bug 574052
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-21 08:25 EST by Sebastian Vahl
Modified: 2010-04-16 07:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-16 07:11:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sebastian Vahl 2010-01-21 08:25:35 EST
Description of problem:

# preupgrade-cli --help
/usr/lib/python2.6/site-packages/yum/__init__.py:203: UserWarning: Use .preconf instead of passing args to _getConfig
  warnings.warn('Use .preconf instead of passing args to _getConfig')
Geladene Plugins: blacklist, dellsysidplugin2, fastestmirror, presto, whiteout
Geladene Plugins: dellsysidplugin2, fastestmirror, presto
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-cli.py", line 302, in <module>
    myrelease = pu.getconfig() # sets pu.opts
  File "/usr/share/preupgrade/preupgrade-cli.py", line 135, in getconfig
    opts = self.doUtilConfigSetup()
  File "/usr/share/yum-cli/utils.py", line 99, in doUtilConfigSetup
    (opts, self.cmds) = self._parser.setupYumConfig()
  File "/usr/share/yum-cli/cli.py", line 1157, in setupYumConfig
    (opts, cmds) = self.parse_args()
  File "/usr/lib/python2.6/optparse.py", line 1378, in parse_args
    stop = self._process_args(largs, rargs, values)
  File "/usr/lib/python2.6/optparse.py", line 1418, in _process_args
    self._process_long_opt(rargs, values)
  File "/usr/lib/python2.6/optparse.py", line 1493, in _process_long_opt
    option.process(opt, value, values, self)
  File "/usr/lib/python2.6/optparse.py", line 782, in process
    self.action, self.dest, opt, value, values, parser)
  File "/usr/lib/python2.6/optparse.py", line 802, in take_action
    self.callback(self, opt, value, parser, *args, **kwargs)
  File "/usr/share/yum-cli/cli.py", line 1275, in _wrapOptParseUsage
    self.base.usage()
  File "/usr/share/yum-cli/cli.py", line 1046, in usage
    sys.stdout.write(self.optparser.format_help())
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe4' in position 2059: ordinal not in range(128)



Version-Release number of selected component (if applicable):
preupgrade-1.1.4-1.fc11.noarch

How reproducible:
ever

Steps to Reproduce:
1. preupgrade --help

Actual results:
backtrace

Expected results:
--help

Additional info:
'LANG=C preupgrade --help' is working.
Comment 1 Dan Horák 2010-04-16 07:11:58 EDT

*** This bug has been marked as a duplicate of bug 574052 ***

Note You need to log in before you can comment on or make changes to this bug.