Bug 55744 - g++ compiling bug
g++ compiling bug
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 64308 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-05 17:23 EST by Florent
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-06 14:16:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Florent 2001-11-05 17:23:38 EST
Description of Problem:
I'm using QT designer 3.0 and the qmake command to generate a Makefile from
my qtproject.
As soon as I type make, it doesn't compile...
Is it a Makefile bug or a g++ bug ??

g++ -c -pipe -Wall -W -g -D~/myfolder -I../myfolder -I/usr/local/qt/include
-I.ui/ -I.moc/ -I/usr/local/qt/mkspecs/default -o .obj/myfile.o myfile.cpp
<command line>: macro names must be identifiers
g++: Internal error: Segmentation fault (program cpp0)
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make: *** [.obj/myfile.o] Error 1


Version-Release number of selected component (if applicable):


How Reproducible:
I don't know


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:
files compiled...

Additional Information:
Comment 1 Jakub Jelinek 2001-11-06 14:16:45 EST
It is both a bug in your Makefile and in cpp, but the one in cpp
has a fix scheduled already for some time into 2.96-100.
2001-05-27  Neil Booth  <neil@daikokuya.demon.co.uk>

        * cpplib.c (run_directive): Set pfile->directive.

--- gcc/cpplib.c.jj     Fri Oct 12 16:49:21 2001
+++ gcc/cpplib.c        Thu Oct 18 10:53:03 2001
@@ -398,7 +398,8 @@ run_directive (pfile, dir_no, type, buf,

   start_directive (pfile);
   pfile->state.prevent_expansion++;
-  (void) (*dtable[dir_no].handler) (pfile);
+  pfile->directive = &dtable[dir_no];
+  (void) (*pfile->directive->handler) (pfile);
   pfile->state.prevent_expansion--;
   check_eol (pfile);
   end_directive (pfile, 1);

The bug in the Makefile is -D~/myfolder, defineds need to be identifiers.
You probably want something like -DHOME=`echo ~/myfolder`.
Comment 2 Jakub Jelinek 2001-11-28 08:05:24 EST
The fix is in 2.96-100 and above.
Comment 3 Jakub Jelinek 2002-05-02 06:48:41 EDT
*** Bug 64308 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2002-07-26 17:47:32 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2002-055.html

Note You need to log in before you can comment on or make changes to this bug.