Bug 55745 - Anaconda fails during installation to Pentium 4 system (see descriptions for details)
Anaconda fails during installation to Pentium 4 system (see descriptions for ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-05 17:31 EST by Ivan Poddubny
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-05 17:31:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Poddubny 2001-11-05 17:31:27 EST
Description of Problem:
During installation to Pentium-4 system with AIC-7892b SCSI controller
anaconda fails.
The actual fall happens when anaconda goes to package selection stage of
installation. 
Anaconda shows following errors:

Traceback (innermost last):
File "/usr/bin/anaconda", line 343, in ? intd.run (todo, test = test)
File "/usr/lib/anaconda/text.py", line 1165, in run rc = apply (step[1](),
step [2])
File "/usr/lib/anaconda/textw/packages.py", line 11, in __call__
todo.getCompsList()
File "/usr/lib/anaconda/todo.py", line 468, in getCompsList self.comps =  
self.method.readComps(self.hdList)
File "/usr/lib/anaconda/image.py", line 8, in readComps return
ComponentSet(self.tree + '/RedHat/base/comps', hdlist)
File "/usr/lib/anaconda/comps.py", line 326, in __init__
self.readCompsFile(file,self.packages)
File "/usr/lib/anaconda/comps.py", line 299, in readCompsFile
comp.addPackage(packages[l])
File "/usr/lib/anaconda/comps.py", line 46, in __getitem__ return
self.packages[item]
KeyError: basesystem

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. take Dell Precision 530 system (I've this system, but I'm sure other
systems with AIC-7892b have same problem)
2. begin with text mode installation of 6.2
3. follow standard procedure of installation; do not specify any parameters
in "Linear mode..."

Actual Results:
installer hangs.

Expected Results:
Fix :)

Additional Information:
I believe this is problem of module aic7xxx which is loading during
installation. I've tried with updated boot images from errata and got the
same result. RedHat 7.1 works normal on the same machine. RH 7.0 installs
without errors but after rebuuting falls to loop with initialisation SCSI.
This is not a problem of my CD with RH 6.2 -- I've tried at least 10 CDs.
Comment 1 Brent Fox 2001-11-08 12:47:40 EST
7.0 was the first release with Pentium 4 support.  I'm afraid that you are
pretty much stuck unless you can use a newer release.
Comment 2 Jesper Brouer 2002-01-02 13:16:49 EST
I have the exact same problem, with RedHat 6.1, also on a Pentium 4 system.
... with IDE disks.

I'm maintaning approx 50 linux machines with RedHat 6.1 kickstart ... and would
like to run Redhat 6.1 on my new machines ... guess I just have to upgrade to an
newer version, which means a lot of work ;-(
Comment 3 Ivan Poddubny 2002-01-02 15:46:41 EST
I've fixed the problem with SCSI. The responce I've got from RedHat support
(sorry folks) stupid. This is not a Pentium-4 problem this is bad SCSI drivers
problem. The Python scripts in my error message NOT RELATED to processor, they
related to Package selection step (actually, the step before Package selection,
when anaconda makes an initialisation of disks). The drivers in basic RedHat
kernel from 2.2 branch are not supporting Ultra-160 SCSI interface (at least the
support for this interface is bad).

The solution for Dell Precision 530: get kernel-2.2.19  (I choose this version).
from RedHat updates, now get patch by Justin Gibbs (at least 6.2.4;
http://people.freebsd.org/~gibbs/linux/) and make changes to fit RedHat kernel
(Justin's patch good for "clean" kernel but will fail on RedHat's). Then you
should make new kernel RPMs and incorporate those RPMs to RedHat CD. Burn the CD
and make installation (I'm assuming that you know how to build new RedHat
instllation CD with new kernel).

Note You need to log in before you can comment on or make changes to this bug.