Bug 55747 - Installation on many toshiba laptops for pcmica is incorrect
Summary: Installation on many toshiba laptops for pcmica is incorrect
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-06 02:03 UTC by Andrew C. Oliver
Modified: 2006-02-21 18:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:48:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew C. Oliver 2001-11-06 02:03:21 UTC
Description of Problem:

On a Toshiba 2065CDS and reported at least on the 2100CDT
(http://www.xmission.com/~bradipo/toshiba/Toshiba_2100CDT.html#pcmciaadjust)
the
pcmica hangs on boot due to a configuration problem.

Version-Release number of selected component (if applicable):

Occurs in 7.0/7.1/7.2  (but not in 6.2!)

How Reproducible:

100% of the time

Steps to Reproduce:
1. Install redhat on a toshiba laptop (probably any with i82365 PCIC)
2. boot
3. will crash at pcmica statup

Actual Results:


Expected Results:


Additional Information:
	
If anaconda were to detect this box and stick this in /etc/sysconfig/pcmcia
life would be much better and I'd have used my laptop alot more *g*.

PCMCIA=yes
PCIC=i82365
PCIC_OPTS="wakeup=1 do_scan=0"
CORE_OPTS=
CARDMGR_OPTS="-f "


After doing this the box boots happily.  We'll see if I can get my network
card installed (wouldn't that be a kick in the pants.)

GO here if you need more info:

http://www.xmission.com/~bradipo/toshiba/Toshiba_2100CDT.html#pcmciaadjust

Comment 1 Brent Fox 2001-11-09 04:10:54 UTC
So the install completes ok, but then has problems on reboot?  Did you do a
laptop class installation?

Comment 2 Andrew C. Oliver 2001-11-09 13:24:50 UTC
Yes, the install completes.  I did do a laptop install.  On boot it gets right
to where it tries to bring up pcmcia then hangs.  

There is practically nothing in /etc/sysconfig/pcmcia.  When I add the above
everything works as normal.  There is documentation on this at the above url as
well as toshiba uk's linux page (for instance showing which PCIC is in which
laptop, fortunately the example at the url was the same guts as mine though it's
a different model laptop).  

A quick search in google for "redhat i82365" reveals several users with problems
like this.  There is also this sysconfig howto which is curious (it mentions i82365)

http://www.redhat.com/support/resources/howto/sysconfig.html

Comment 3 Michael Fulbright 2002-02-13 21:03:19 UTC
Bill isn't this file created by kudzu?

Comment 4 Bill Nottingham 2002-02-13 21:09:48 UTC
No, kudzu doesn't touch /etc/sysconfig/pcmcia. The loader/installer writes it.

Comment 5 Michael Fulbright 2002-03-26 17:32:39 UTC
Deferring to future release.

Comment 6 Red Hat Bugzilla 2006-02-21 18:48:14 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.