Bug 55748 - [margins] Problems printing to LaserJet 6L
[margins] Problems printing to LaserJet 6L
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-05 21:45 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-10 11:57:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/spool/lpd/lpd/status.lpd - shows the errors (7.91 KB, text/plain)
2001-11-05 21:46 EST, Need Real Name
no flags Details
/etc/printcap - the printer configuration file printconf-tui generates (760 bytes, text/plain)
2001-11-05 21:47 EST, Need Real Name
no flags Details
the output from rpm -qa showing all the packages/patches on my system (4.11 KB, text/plain)
2001-11-05 21:47 EST, Need Real Name
no flags Details
/etc/xinetd.d/printer - to launch the lpr emulation through CUPS (310 bytes, text/plain)
2001-11-19 20:40 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-11-05 21:45:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.16-22 i686)

Description of problem:
I've been an avid linux user now for many years. I've been using a LaserJet
6L printer attached to a linux file server for the last 3 years without a
problem, first on RHL 5.2, then on 7.0. Well, I just rebuilt my server with
RHL7.2 and can no longer print. I'm using printconf-tui to generate the
printer config (X? on a server? dont be silly...) and it seems to generate
/etc/printcap fine. Firing off a test page (ASCII and Postscript) from
within printconf-tui fails, and printing from the command line with the
usual tools (lp/lpr) also does not work. However, I know the hardware is
all working properly; using cat FILENAME > /dev/lp0  spits FILENAME out the
printer.

I'll walk through the process of creating the printer and then firing off
the test pages to help reproduce the environment and situation. This will
start from having no printer configured at all.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Launch printconf-tui.
2. Choose new.
3. Select a queue name. I use lpd, but what's in a name?
4. Leave Local Printer Device selected, and tab down to Next.
5. /dev/lp0 is highlighted. Tab down to next.
6. Under HP, select LaserJet 6L, and select the ljet4 driver. Tab and
select next.
7. Select Finish.
8. Tab over to the Test button.
9. Saving is a good thing. Choose Yes.
10. Arrow down to ASCII text testpage, then hit tab and choose test.
11. Sent ASCII test page to "lpd". Hit OK.
12. Hit enter to choose Test again.
13. US Letter Postscript Testpage is automatically highlighted. Hit tab to
choose test.
14. Sent US Letter PostScript Testpage to "lpd". Hit OK.
15. Tab and choose Exit to end printconf-tui.

	

Actual Results:  Nothing. The printer wakes up (bottom light comes on) but
nothing ever comes out.

Expected Results:  Test pages!


Additional info:

I'll attach the resulting files:
/etc/printcap
/var/spool/lpd/lpd/status.lpd

and the output of rpm -qa. Please note that I'm running all the latest
updates from RedHat. I've tried rolling back the updates (removing the 2
Omni packages, rolling back ghostscript and printconf to stock RH7.2) but
that wasnt successful either; it produced a different set of errors.
Comment 1 Need Real Name 2001-11-05 21:46:09 EST
Created attachment 36542 [details]
/var/spool/lpd/lpd/status.lpd - shows the errors
Comment 2 Need Real Name 2001-11-05 21:47:09 EST
Created attachment 36543 [details]
/etc/printcap - the printer configuration file printconf-tui generates
Comment 3 Need Real Name 2001-11-05 21:47:51 EST
Created attachment 36544 [details]
the output from rpm -qa showing all the packages/patches on my system
Comment 4 Scott Dowdle 2001-11-19 15:23:34 EST
I'm trying to print to a local printer... HLaserJet 5P.  I discovered the same
thing... it used to work in previous versions of RHL but won't work with 7.2. 
Yes, I have upgraded to the latest updates of everything.

The printconf program discovers the printer just fine but does nothing when a
test page is supposed to be printed.

Where do we go from here?
Comment 5 Need Real Name 2001-11-19 20:39:06 EST
I gave up, since I haven't heard a response. I downloaded the latest version of
CUPS (http://www.cups.org/, version 1.1.12). Sweeeeeet product. Installed it,
hit the web interface, chose my parallel port, and it had already detected the
LaserJet 6L. Fired off a test page, and voila, all was happy. However, I did
need to enable the lpr emulation for my RH7.0 workstations. I'll attach the
xinetd.d file entry.
Comment 6 Need Real Name 2001-11-19 20:40:30 EST
Created attachment 37985 [details]
/etc/xinetd.d/printer - to launch the lpr emulation through CUPS
Comment 7 Need Real Name 2001-12-01 06:12:37 EST
I upgrade RH 7.0 to 7.2.
I used that new printtool and added my laserjet HP6L.
It works via D-link print server  "net paraller port".  
I can print, but some pcl setup command are printed
as text to firsth page and then FF.
Second page is what I am waiting for
Orvo Leinonen
orvo.leinonen@operafin.fi
Comment 8 Need Real Name 2001-12-06 11:59:44 EST
I have tried upgrate newest version of LPRng without any help.
Last I chose driver "LaserJet Plus ljetplus" instead  "LasetJet 6L ljet4".
Then it works nearly right. 
Only margins was not exactly what they had to be by A4 Postcripts
test page.

Maybe some one who has done those drivers could be easily correct that 
problems because that one works nearly right and I think they mayby are
nearly same.
Comment 9 Peter Toft 2001-12-10 16:41:51 EST
With the updated version LPRng-3.7.4-28 I now can print with RH7.2 on my 
HP LaserJet 6L on A4 paper (see below regarding the necessary updates), 
but the top margin is offset negative (some text disappears) between 
1.5cm and 2 cm. I do not know to to correct this - hints hints :)

I have not understood how foomatic, LPRng etc are connected, but have applied
http://www.redhat.com/support/errata/RHBA-2001-155.html and 
http://www.redhat.com/support/errata/RHBA-2001-155.html to the standard RH7.2
Comment 10 Tim Waugh 2002-01-10 11:57:50 EST
I wonder if this margins problem is the same as the one in bug #54412.
Comment 11 Tim Waugh 2002-03-06 05:13:28 EST
I'm going to close this because the original bug is fixed.  For the margins
issue please see bug #54412.

Note You need to log in before you can comment on or make changes to this bug.