Bug 55749 - cvs pserver login problems
Summary: cvs pserver login problems
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cvs (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
high
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-06 04:22 UTC by cbj
Modified: 2007-03-27 03:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-08 16:02:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description cbj 2001-11-06 04:22:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
All attempts to use a pserver (login, update) are failing with an internal
error.  This does not appear to be a problem when using CVS with ssh for
instance with CVS_RSH=ssh and a repository like
:ext:user@savannah.gnu.org:/cvsroot/...



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.cvs -d :pserver:anoncvs@sources.redhat.com/cvs/kawa login
2.Type 'anoncvs' and press the ENTER key at the login prompt

OR

Pick any previous cvs checkout you'd like to update that uses pserver and
try to perform an update.  The same error message should appear except it
should say "updated aborted".


Actual Results:  cvs [login aborted]: internal error: get_cvs_port_number
called for invalid connection method (ext): Invalid argument

Expected Results:  Normal login or update from CVS.

Additional info:

This would seem to be a big problem for any developers commonly using
anonymous CVS pserver access to acquire things like gcc.  I'm going to try
reverting to cvs from Red Hat 7.1 since I know that worked.

$ cvs --version

Concurrent Versions System (CVS) 1.11.1p1 (client/server)

Copyright (c) 1989-2001 Brian Berliner, david d `zoo' zuhn, 
                        Jeff Polk, and other authors

CVS may be copied only under the terms of the GNU General Public License,
a copy of which can be found with the CVS distribution kit.

Specify the --help option for further information about CVS

Comment 1 Eido Inoue 2004-10-08 16:02:57 UTC
could not reproduce using steps provided with current releases


Note You need to log in before you can comment on or make changes to this bug.