Bug 557538 - nautilus-python fails to init on x86_64
Summary: nautilus-python fails to init on x86_64
Keywords:
Status: CLOSED DUPLICATE of bug 474428
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus-python
Version: 12
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-21 18:43 UTC by Justin Dick
Modified: 2010-01-27 20:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-27 20:24:12 UTC
Type: ---


Attachments (Terms of Use)

Description Justin Dick 2010-01-21 18:43:02 UTC
Description of problem:
nautilus-python tries to bind to 32-bit version of libpython2.6.so rather than 64-bit version.  '.xsession-errors' shows the following:

Initializing nautilus-search-tool extension
Initializing nautilus-gdu extension

(nautilus:11356): Nautilus-Python-WARNING **: g_module_open libpython failed: /usr/lib/libpython2.6.so: cannot open shared object file: No such file or directory
Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/gtk-2.0/gobject/__init__.py", line 26, in <module>
    from glib import spawn_async, idle_add, timeout_add, timeout_add_seconds, \
  File "/usr/lib64/python2.6/site-packages/gtk-2.0/glib/__init__.py", line 22, in <module>
    from glib._glib import *
ImportError: /usr/lib64/libpyglib-2.0-python.so.0: undefined symbol: PyExc_ImportError

(nautilus:11356): Nautilus-Python-WARNING **: could not import gobject

(nautilus:11356): Nautilus-Python-WARNING **: pygobject initialization failed

(nautilus:11356): Nautilus-Python-WARNING **: nautilus_python_init_python failed
Initializing nautilus-open-terminal extension



***Installing the 32-bit python-devel package gives the following:
(nautilus:11359): Nautilus-Python-WARNING **: g_module_open libpython failed: /usr/lib/libpython2.6.so: wrong ELF class: ELFCLASS32



Version-Release number of selected component (if applicable):
This exists in both nautilus-python-0.5.1-5.fc12.x86_64 and nautilus-python-0.5.1-4.fc11.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1. Restart nautilus, watch .xsession-errors
2. Note that no functionality based on nautilus-python is available
  
Additional info:

*** Workaround ***:
ln -s ../lib64/libpython2.6.so /usr/lib/

With this workaround, everything works.

Comment 1 Toshio Ernie Kuratomi 2010-01-27 20:24:12 UTC
This package is currently an orphan.  Marking bug as a duplicate but we need someone to take over maintainership.

*** This bug has been marked as a duplicate of bug 474428 ***


Note You need to log in before you can comment on or make changes to this bug.