Bug 557549 - SELinux is preventing /usr/sbin/semodule access to a leaked /root/.xsession-errors file descriptor.
Summary: SELinux is preventing /usr/sbin/semodule access to a leaked /root/.xsession-e...
Keywords:
Status: CLOSED DUPLICATE of bug 543970
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:a36a637513e...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-21 19:25 UTC by adrian1h
Modified: 2010-01-27 18:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-21 19:46:32 UTC


Attachments (Terms of Use)

Description adrian1h 2010-01-21 19:25:49 UTC
Summary:

SELinux is preventing /usr/sbin/semodule access to a leaked
/root/.xsession-errors file descriptor.

Detailed Description:

[semodule has a permissive type (semanage_t). This access was not denied.]

SELinux denied access requested by the semodule command. It looks like this is
either a leaked descriptor or semodule output was redirected to a file it is not
allowed to access. Leaks usually can be ignored since SELinux is just closing
the leak and reporting the error. The application does not use the descriptor,
so it will run properly. If this is a redirection, you will not get output in
the /root/.xsession-errors. You should generate a bugzilla on selinux-policy,
and it will get routed to the appropriate package. You can safely ignore this
avc.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385)

Additional Information:

Source Context                unconfined_u:unconfined_r:semanage_t:s0-s0:c0.c102
                              3
Target Context                unconfined_u:object_r:admin_home_t:s0
Target Objects                /root/.xsession-errors [ file ]
Source                        semodule
Source Path                   /usr/sbin/semodule
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           policycoreutils-2.0.78-3.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-66.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   leaks
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31.9-174.fc12.i686.PAE #1
                              SMP Mon Dec 21 06:04:56 UTC 2009 i686 athlon
Alert Count                   2
First Seen                    Sun 10 Jan 2010 01:43:01 AM EST
Last Seen                     Sun 10 Jan 2010 01:43:07 AM EST
Local ID                      d972f559-9f36-4d90-9b6c-e30c948ea7c6
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1263105787.334:21314): avc:  denied  { write } for  pid=3116 comm="semodule" path="/root/.xsession-errors" dev=dm-0 ino=158501 scontext=unconfined_u:unconfined_r:semanage_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1263105787.334:21314): arch=40000003 syscall=11 success=yes exit=0 a0=89c23a0 a1=89c2598 a2=89c1920 a3=89c2598 items=0 ppid=3109 pid=3116 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=8 comm="semodule" exe="/usr/sbin/semodule" subj=unconfined_u:unconfined_r:semanage_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-66.fc12,leaks,semodule,semanage_t,admin_home_t,file,write
audit2allow suggests:

#============= semanage_t ==============
allow semanage_t admin_home_t:file write;

Comment 1 Daniel Walsh 2010-01-21 19:46:32 UTC
root logins not supported.

*** This bug has been marked as a duplicate of bug 543970 ***


Note You need to log in before you can comment on or make changes to this bug.