Bug 557660 - Window guest got "Display Driver Stopped Responding" error and BSOD when running 15 loaded guest at the same time
Window guest got "Display Driver Stopped Responding" error and BSOD when runn...
Status: CLOSED DUPLICATE of bug 680341
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
All Linux
low Severity medium
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
: Triaged
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-01-22 00:15 EST by lihuang
Modified: 2013-01-09 17:14 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-11 11:07:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Display Driver Stopped Responding (162.68 KB, image/png)
2010-01-22 00:17 EST, lihuang
no flags Details
BSOD (16.91 KB, image/png)
2010-01-22 00:17 EST, lihuang
no flags Details
minidump (10.62 KB, text/plain)
2010-01-22 00:20 EST, lihuang
no flags Details

  None (edit)
Description lihuang 2010-01-22 00:15:28 EST
Description of problem:
(copy from bug 553249#c11 ~ 553249#c14)
there are 15 window xp guest running simultaneously. connecting by vnc.
10 of them are loaded by iometer and cpuhog.
the host is Intel Core(TM)2 Quad Q9400, 4cores. (detail in additional infor )

several hours later. in guest. a warning dialog "Display Driver Stopped Responding" pop up. and finally guest BSOD.(log will upload )

CLI :
root      6669  3957 64 Jan19 pts/0    01:23:18 /usr/libexec/qemu-kvm -m 1024
-smp 1 -drive file=winXP-32.raw,if=ide -net nic,macaddr=DE:AD:BE:EF:00:00 -net
tap -boot c -uuid debd696c-a5b0-4ec9-98e4-329fdbeab007 -usbdevice tablet
-rtc-td-hack -no-kvm-pit-reinjection -monitor stdio -notify all -balloon none
-vnc :1 -vmchannel di:0200,tcp:0:7890,server,nowait -drive
file=/data/t200/test,if=ide -name t200:1


when I test 5 vms with vnc,all vms are healthy in the 12 hour testing.
when I test 15 vms with spice, vms also healthy in the 36 hour testing.

 
Version-Release number of selected component (if applicable):
kvm-83-105.el5_4.19

How reproducible:
I just test once. all guest BSOD.


Steps to Reproduce:
1.start as many as possible window guest with vnc
2.in guest,generate i/o and cpu load 
3.
  
Actual results:


Expected results:


Additional info:

processor       : 3
vendor_id       : GenuineIntel
cpu family      : 6
model           : 23
model name      : Intel(R) Core(TM)2 Quad CPU    Q9400  @ 2.66GHz
stepping        : 10
cpu MHz         : 2660.003
cache size      : 3072 KB
physical id     : 0
siblings        : 4
core id         : 3
cpu cores       : 4
apicid          : 3
fpu             : yes
fpu_exception   : yes
cpuid level     : 13
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc pni monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr sse4_1 lahf_lm
bogomips        : 5319.98
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:
Comment 1 lihuang 2010-01-22 00:17:00 EST
Created attachment 386087 [details]
Display Driver Stopped Responding
Comment 2 lihuang 2010-01-22 00:17:43 EST
Created attachment 386088 [details]
BSOD
Comment 3 lihuang 2010-01-22 00:20:35 EST
Created attachment 386089 [details]
minidump
Comment 4 Gerd Hoffmann 2010-01-26 03:42:04 EST
What kind of tests do the iometer instances run?  Network?  Disk?  Both?
Was a vnc viewer connected while running the tests?
Comment 5 lihuang 2010-01-28 04:43:51 EST
(In reply to comment #4)
> What kind of tests do the iometer instances run?  Network?  Disk?  Both?
> Was a vnc viewer connected while running the tests?    

only Disk testing . read/write, QD from 1 to 32.
and vnc is connecting during whole test.
Comment 9 RHEL Product and Program Management 2011-01-11 15:29:10 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 10 RHEL Product and Program Management 2011-01-11 17:49:12 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 11 Dor Laor 2011-04-06 08:17:14 EDT
Not sure if it is fixable, MS has a watch dog timer, if the host is too loaded we won't be schedule the guests fast enough. We need to find the registry setting to disable it and state that over release notes (similar of rhel6 as well)
Comment 12 Vadim Rozenfeld 2011-04-06 08:49:19 EDT
Please try disabling the display watchdog.
http://msdn.microsoft.com/en-us/library/ff553890%28v=vs.85%29.aspx
Comment 13 Ronen Hod 2011-08-11 11:07:40 EDT

*** This bug has been marked as a duplicate of bug 680341 ***

Note You need to log in before you can comment on or make changes to this bug.