Bug 55773 - reiserfs causes forced fsck failure at boot
reiserfs causes forced fsck failure at boot
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: reiserfs-utils (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-06 09:11 EST by Andrew Pam
Modified: 2013-07-02 22:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-22 11:50:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Pam 2001-11-06 09:11:12 EST
Description of Problem:
On an unclean shutdown, rc.sysinit asks if you want to force an fsck.
Unfortunately it implements this by calling fsck against each mountpoint
with the "-f" option which is not implemented in fsck.reiserfs and returns
with an error code, resulting in rc.sysinit incorrectly concluding that the
fsck failed and forcing a reboot.

Version-Release number of selected component (if applicable):
initscripts-6.40-1, reiserfs-utils-3.x.0j-2

How Reproducible:
Every time.

Steps to Reproduce:
1. On my system, all filesystems are journalled - a mix of ext3 and reiserfs
2. Shut down without removing /.autofsck
3. When asked to press "f" to force an fsck, do so.

Actual Results:
Any non-reiserfs fscks will proceed normally, but at the first
reiserfs mountpoint it will fail to run fsck (since "-f" is not a valid
option to fsck.reiserfs) and you will have to reboot again without having
actually run the fsck.  You will have to start without the reiserfs
partitions mounted and fsck them manually if desired.

Expected Results:
fsck.reiserfs should have been run without the non-existent "-f" option.
Alternatively, "-f" should be added to reiserfsck as an ignored option.
Comment 1 Bill Nottingham 2001-11-06 10:57:48 EST
'"-f" should be added to reiserfsck as an ignored option' sounds like the
correct solution to me.
Comment 2 Tomas Mraz 2005-04-22 11:50:45 EDT
This is already fixed.

Note You need to log in before you can comment on or make changes to this bug.