Bug 557862 - Liberation Mono is not really monospaced font
Liberation Mono is not really monospaced font
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-22 13:03 EST by Kir Kolyshkin
Modified: 2010-10-18 01:41 EDT (History)
4 users (show)

See Also:
Fixed In Version: liberation-fonts-1.06.0.20100721-3.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-25 03:43:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lmbug1.png (17.98 KB, image/png)
2010-01-22 13:03 EST, Kir Kolyshkin
no flags Details
lmbug2.png (43.41 KB, image/png)
2010-01-22 13:04 EST, Kir Kolyshkin
no flags Details
lmbug3.png (19.86 KB, image/png)
2010-01-22 13:05 EST, Kir Kolyshkin
no flags Details
lmbug4.png (38.70 KB, image/png)
2010-01-22 13:05 EST, Kir Kolyshkin
no flags Details

  None (edit)
Description Kir Kolyshkin 2010-01-22 13:03:22 EST
Description of problem:
When using Liberation Mono as a default monospace font in Firefox,
I have noticed that the lines of equal width (in terms of characters)
all have different width. It can clearly be seen on a screenshots that
I will attach shortly.

It took me about 15 minutes to understand it. I tried with Andale Mono and it looks fine.

Version-Release number of selected component (if applicable):
$ rpm -q liberation-mono-fonts liberation-fonts-common fontconfig freetype firefox fedora-release
liberation-mono-fonts-1.05.1.20090721-2.fc12.noarch
liberation-fonts-common-1.05.1.20090721-2.fc12.noarch
fontconfig-2.8.0-1.fc12.x86_64
fontconfig-2.8.0-1.fc12.i686
freetype-2.3.11-3.fc12.x86_64
freetype-2.3.11-3.fc12.i686
firefox-3.5.6-1.fc12.x86_64
fedora-release-12-2.noarch


How reproducible:
always

Steps to Reproduce:
1. make sure liberation mono is installed (rpm -q liberation-mono-fonts) and available (fc-match 'liberation mono')
2. Open this page in your browser http://kir.sacred.ru/tmp/liberation-mono.html
3. Try increasing/decreasing text size (in case of Firefox use Ctrl with +/-).
  
Actual results:
Lines are of different width

Expected results:
Lines are of the same width

Additional info:
Comment 1 Kir Kolyshkin 2010-01-22 13:03:54 EST
Created attachment 386212 [details]
lmbug1.png
Comment 2 Kir Kolyshkin 2010-01-22 13:04:27 EST
Created attachment 386213 [details]
lmbug2.png
Comment 3 Kir Kolyshkin 2010-01-22 13:05:01 EST
Created attachment 386214 [details]
lmbug3.png
Comment 4 Kir Kolyshkin 2010-01-22 13:05:23 EST
Created attachment 386215 [details]
lmbug4.png
Comment 5 Kir Kolyshkin 2010-01-22 13:11:03 EST
(1) I consider this is a major bug.

(2) A very interesting thing (if you look at screenshots) is we have different relative line widths on different font sizes: say on lmbug3.png line #3 is longest, while on lmbug1.png and lmbug2.png it is shortest!
Comment 6 Kir Kolyshkin 2010-01-22 13:50:24 EST
This is becoming even more interesting. On a colleague's system (Fedora 11) it looks fine, here's the versions of packages she have:

$ rpm -q liberation-mono-fonts liberation-fonts-common fontconfig freetype firefox fedora-release
liberation-mono-fonts-1.04.93-10.fc11.noarch
liberation-fonts-common-1.04.93-10.fc11.noarch
fontconfig-2.8.0-1.fc11.x86_64
fontconfig-2.8.0-1.fc11.i586
freetype-2.3.9-5.fc11.i586
freetype-2.3.9-5.fc11.x86_64
firefox-3.5.6-1.fc11.x86_64
fedora-release-11-1.noarch
Comment 7 Kir Kolyshkin 2010-01-22 13:53:45 EST
Firefox is not guilty -- I have just reproduced the issue using Mousepad text editor from XFCE.
Comment 8 Kir Kolyshkin 2010-01-22 14:04:19 EST
Downgrading freetype to version from F11 (ie 2.3.9-5) not helped.

Rebuilding the font package from src (liberation-fonts-1.05.1.20090721-2.fc12.src.rpm) not helped

*Downgrading the font package (to a version from F11, ie 1.04.93-10.fc11) did helped!*

So the problem lies somewhere in between 1.0.4 and 1.0.5
Comment 9 Kir Kolyshkin 2010-01-22 14:12:12 EST
OK I guess it's dupe of #508899
Comment 10 Kir Kolyshkin 2010-01-22 14:12:25 EST
OK I guess it's dupe of bug #508899
Comment 11 Kir Kolyshkin 2010-01-25 03:43:47 EST

*** This bug has been marked as a duplicate of bug 508899 ***
Comment 12 Fedora Update System 2010-10-13 00:49:07 EDT
liberation-fonts-1.06.0.20100721-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/liberation-fonts-1.06.0.20100721-3.fc14
Comment 13 Fedora Update System 2010-10-18 01:41:15 EDT
liberation-fonts-1.06.0.20100721-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.