Bug 55793 - Installer hangs while installing RPM's using I2O
Installer hangs while installing RPM's using I2O
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-06 14:54 EST by Chris Stevens
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-07 01:43:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Stevens 2001-11-06 14:54:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.5 i686)

Description of problem:
The installer hangs while installing RPMS's.  I have a Adaptec 3400S SCSI
RAID card.  The I2O driver is loaded by the install program for this card. 
The installer goes through all the prompts and then starts loading
packages.  It hangs soon after, not always on the same package.  I am using
the current updates disk image when installing.  I have tried installing
from burned CDR's and from the disk images off the hard drive.  Switching
to the F2 terminal, I can do commands such as ps -aux.  When I try to do ls
of the mounted filesystems, ls just hangs.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot install floppy
2.at prompt use linux dd updates
3. proceed through install prompts
	

Actual Results:  I get a progress bar.  Sometimes the  install hangs right
away.  Other times a few packages get installed first.

Expected Results:  A complete install.

Additional info:

install log file shows no errors up to the point of system hang.
Comment 1 Albert Cheung 2001-11-07 01:43:14 EST
Hello there,

I am also experiencing similar installation problem here -- RedHat 7.2 with 
Adaptec ATA RAID 2400A card (i2o chipset based).

The RedHat 7.2 installer detects my RAID controller okay with its kernel built-
in driver but the installer freezes when it trys to format my RAID drives or 
install RPMs.

I have tried to install the same RAID card in systems with the older RedHat 
versions and RedHat 6.2, RedHat 7.0 and RedHat 7.1 seem to be working fine with 
my RAID card with the driver posted on Adaptec's website.

How reproducible:
Always


Steps to Reproduce:
1. install Redhat 7.2 from CD-ROM
2. Partition the hard drives and choose to format all partitions
3. When the RedHat tries to format the paritions or install RPMs, it will just 
freeze.

Results:  When the machine starts to Format the disk it runs for about 8 - 12 
pct. of the disk and it stops.

Comment 2 Tom "spot" Callaway 2001-11-08 11:01:28 EST
The i2o driver is the incorrect driver for the Adaptec I2O cards (virtually all
of their hardware RAID controllers).

To install Red Hat Linux 7.2 onto a device attached to an Adaptec I2O card,
follow the instructions here:

http://people.redhat.com/tcallawa/dpt/

The dd initrd problem in anaconda should be fixed in rawhide, as well as the
incorrect PCI table entry that causes Adaptec I2O cards to be misdetected.
Comment 3 Albert Cheung 2001-11-08 16:20:09 EST
I have tried the installer image files posted on 
http://people.redhat.com/tcallawa/dpt/ but I experience
kernel panic error after RedHat 7.2 installation. Here are the error messages 
that my RedHat 7.2 boot up screen generates:

/lib/dpt_i2o.o: unresolved symbol register_chrdev_R82739b6c
/lib/dpt_i2o.o: unresolved symbol scsi_register_R7998745a
ERROR: /lib/insmod exited abnormally!
:
:
Kernel panic: No init found. Try passing init= option to kernel.

FYI, I am using AMD Althon T-bird 1400Mhz CPU with 
Adaptec ATA RAID 2400A. Guess the driver image files are really for
Pentium CPUs but not for AMD CPUs.

Note You need to log in before you can comment on or make changes to this bug.