Bug 55823 - xemacs-21.4.5-1 dumps core
Summary: xemacs-21.4.5-1 dumps core
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: xemacs (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-07 09:05 UTC by Jens Petersen
Modified: 2007-04-18 16:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-13 06:42:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jens Petersen 2001-11-07 09:05:17 UTC
Description of Problem:
Dumps core on start up.

Version-Release number of selected component (if applicable):
21.4.5-1

How Reproducible:
Always

Steps to Reproduce:
1. xemacs

Actual Results:

Fatal error (11).

:

Lisp backtrace follows:  

  # bind (frame-being-created)
  make-frame(nil #<x-device on ":0.0" 0x243e>)
  frame-initialize()
  # bind (debugger debug-on-error command-line-args-left)
  command-line()
  # (unwind-protect ...) 
  normal-top-level()
  # (condition-case ... . error)
  # (catch top-level ...)
zsh: segmentation fault  xemacs-21.4.5


Expected Results:
No core dump.

Additional Information:
Rebuilding without lesstiff-devel installed fixed the problem for me.

Comment 1 Trond Eivind Glomsrxd 2001-11-07 16:34:57 UTC
Rebuilding on your system should solve it  even without that change - something
isn't quite right in that buildroot. Keeping open, will close when it's rebuilt
some day in the future.

Comment 2 Enrico Scholz 2001-11-07 20:47:08 UTC
Sounds like http://list-archive.xemacs.org/xemacs-beta/200110/msg00286.html ...

(solution is given there also)

Comment 3 Trond Eivind Glomsrxd 2001-11-07 20:52:32 UTC
He didn't use lesstif, so that theory is abandoned.

Comment 4 Enrico Scholz 2001-11-07 21:02:05 UTC
Bug in msg00286 is not a lesstif issue, but a binutils one (perhaps triggered by
lesstif). 

I see similar coredumps with rawhide binutils-2.11.92.0.7-2, but
binutils-2.11.90.0.8-9 are working fine (I have not tried the solution from the
XEmacs maillist yet).

Comment 5 Jens Petersen 2001-11-08 03:30:51 UTC
Hmmm, I see binutils-2.11.92.0.7-2 is in the buildroot...
Looks like this bug should probably be moved to binutils then.

Comment 6 Jens Petersen 2001-11-08 03:40:57 UTC
Forget to add that indeed rebuilding 21.4.5-1 on a 7.2 box made the problem go
away as you said (ie binutils-2.11.90.0.8-9).

Comment 7 Jens Petersen 2001-11-08 03:58:38 UTC
On second thoughts, after reading the whole thread on the xemacs-list it seems
this is due to an official change in binutils.  So I agree with Enrico that we
should add those ld options to %configure.

Comment 8 Jens Petersen 2001-11-08 08:02:39 UTC
On i386 at least I can reproduce the problem:
xemacs-21.4.5-1 built with binutils-2.11.92.0.7-2
dumps core for me at startup, whereas if I build with
binutils-2.11.90.0.8-9 it works fine.


Comment 9 Jens Petersen 2001-11-09 02:31:06 UTC
Adding '--ldflags=-s -znocombreloc' to the configure options, fixes the problem
with binutils-2.11.92.0.7-2 as expected.



Comment 10 Jens Petersen 2001-11-13 06:41:54 UTC
Strange, though.  For xemacs-21.4.5-1, xemacs -nw runs ok in a tty -- it only
seems to dump core when starting in an X window.

Comment 11 Jens Petersen 2001-11-14 09:05:56 UTC
fixed in xemacs-21.4.5-2.


Note You need to log in before you can comment on or make changes to this bug.