Bug 55825 - /usr/share/libtool/ltconfig disappeared?
/usr/share/libtool/ltconfig disappeared?
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: libtool (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-07 05:00 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-09 07:58:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-07 05:00:34 EST
Description of Problem:

/usr/share/libtool/ltconfig present in RedHat7.1
/usr/share/libtool/ltconfig vanished in RedHat 7.2

Version-Release number of selected component (if applicable):
 
RedHat7.1: 
[ted@lorient ~]$ rpm -qf /usr/share/libtool/ltconfig
libtool-1.3.5-8

How Reproducible:

locate ltconfig
The file is not where it is supposed to be


Additional Information:
I wanted to rebuild scilab-2.6
rpm --rebuild scilab-2.6-1.src.rpm
It does not work because ltconfig is not there
Comment 1 Michael Schwendt 2001-11-07 12:55:01 EST
ltconfig is gone with newer versions of libtool. Unless I'm mistaken,
applications should either include a copy of ltconfig (unfortunately, old
combinations of automake/libtool created just a link) or get fixed.

In the top source dir, run:

  alocal ; automake -a -c ; autoconf

This should solve your problems.
Comment 2 Need Real Name 2001-11-08 04:50:46 EST
I tried what you said:

%prep
%setup -q 
%patch0 -p1
aclocal; automake -a -c; autoconf

%build
cp /usr/share/libtool/{config.sub,config.guess,ltconfig,ltmain.sh} config/
export CFLAGS="$RPM_OPT_FLAGS"
export CC_OPTIONS="$RPM_OPT_FLAGS"
...


but I obtain the following message error:
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.27849
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd /usr/src/redhat/BUILD
+ rm -rf scilab-2.6
+ /bin/gzip -dc /usr/src/redhat/SOURCES/scilab-2.6.src.tar.gz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd scilab-2.6
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ echo 'Patch #0 (scilab-2.6-nopvmdist.patch):'
Patch #0 (scilab-2.6-nopvmdist.patch):
+ patch -p1 -s
+ aclocal
+ automake -a -c
configure.in: 9: `automake requires `AM_CONFIG_HEADER', not `AC_CONFIG_HEADER'
automake: configure.in: `PACKAGE' not defined in `configure.in'
automake: configure.in: `VERSION' not defined in `configure.in'
automake: configure.in: installing `config/mkinstalldirs'
automake: configure.in: installing `config/missing'
automake: no `Makefile.am' found or specified
error: Bad exit status from /var/tmp/rpm-tmp.27849 (%prep)


What have I done wrong?

Daniel
Comment 3 Michael Schwendt 2001-11-08 11:34:28 EST
It doesn't use automake. :)

With

  libtoolize -c --force ; configure ...

one can set up the source tarball and compile with "make all". In your spec
file, you may need to take out the first "cp" line from the %build section and
most likely any "aclocal" and "autoconf" calls, too. The scilab distribution is
broken  when it doesn't come with a working set of files and keeps local macros
in aclocal.m4 instead of acinclude.m4. It will need to get fixed, not only for
libtool > 1.3.5.
Comment 4 Need Real Name 2001-11-09 07:23:58 EST
Thanks for your answer
If I understand correctly what you wrote, Scilab will have anyway problems to
build on RH72? Is that it?
Maybe I should wait for the RH SRPMS...

Daniel
Comment 5 Michael Schwendt 2001-11-09 07:58:49 EST
The way the rpm's spec file sets up the code is incompatible.

Basically, you should need to run just "configure ; make all" like the README
suggests. You should not need to copy over libtool files from your installation
like the spec file does. If you really needed to rebuild
autoconf/automake/libtool files, this would not work completely with scilab
because their setup is broken.

I'm not a Red Hat employee, but since the Powertools CD is no longer produced,
there probably won't be any offically supported RH rpms for scilab.

Note You need to log in before you can comment on or make changes to this bug.