Bug 55842 - libpcap-devel not 'provided' by libpcap RPM nor available as seperate package
Summary: libpcap-devel not 'provided' by libpcap RPM nor available as seperate package
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcpdump   
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-07 17:05 UTC by Dan Moore
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-07 17:05:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Moore 2001-11-07 17:05:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011106

Description of problem:
Unlike every other library package included with RHL 7.2, there is not a
seperate libpcap-devel package -- the libpcap RPM contains all the files
that would be contained in a normal RPM as well as the -devel RPM.

This isn't a big problem, since even the combined RPM is small.  However,
this combined RPM doesn't 'provide' 'libpcap-devel' which may be required
by other packages.  For instance, you cannot --rebuild the SRPM of
ntp-4.1.0-4 that is a part of the base RHL 7.2 distribution since it checks
for libpcap-devel.

PROPOSED SOLUTIONS:
1.  split libpcap's RPM into libpcap and libpcap-devel which 'provide'
'libpcap' and 'libpcap-devel', respectively.
2.  have the libpcap RPM 'provide' both 'libpcap' and 'libpcap-devel'.
3.  change all the RPMs that require 'libpcap-devel' so that they only
require 'libpcap'.

I would think 2 or 1 would be the most desirable.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  $ up2date libpcap
2.  $ up2date libpcap-devel
3.  $ rpm -q --whatprovides libpcap-devel

Actual Results:  "no package provides libpcap-devel"

Expected Results:  "libpcap-0.6.2-9"
OR
"libpcap-devel-0.6.2-9"

Additional info:

Comment 1 Harald Hoyer 2001-12-13 14:59:51 UTC
ntp requires libcap-devel not _p_cap :)



Note You need to log in before you can comment on or make changes to this bug.