Bug 55845 - --buildroot doesn't affect the Build root.
Summary: --buildroot doesn't affect the Build root.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-07 17:42 UTC by Dave Johnson
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-07 17:42:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dave Johnson 2001-11-07 17:42:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
Passing a --buildroot option seems to be ignored.  That is, even when
passing a --buildroot option, RPM looks for source files in the default
build root (/usr/src/redhat) and complains when the source files aren't
there.

Further, using a "buildroot: <path>" option in a .rpmrc results in an error
message: "error: bad option 'buildroot' in /home/johnsond/.rpmrc:1".

Version-Release number of selected component (if applicable):
4.0.2-8

How reproducible:
Always

Steps to Reproduce:
1. rpm -ba <specfile> --buildroot <path to build root>
	

Additional info:

Comment 1 Jeff Johnson 2001-11-15 23:56:08 UTC
You're confusing --buildroot with the macro value
%{_builddir}. And you're probably looking to
change the macro %{_topdir} to something 
other than /usr/src/redhat. Do that by
	echo "%_topdir  /wherever/you/want" >> ~/.rpmmacros


Note You need to log in before you can comment on or make changes to this bug.