Bug 55854 - updatedb seems to fail silently on ext3 filesystems
Summary: updatedb seems to fail silently on ext3 filesystems
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: slocate   
(Show other bugs)
Version: 7.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-07 20:16 UTC by Ben Poliakoff
Modified: 2007-04-18 16:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-15 18:45:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Poliakoff 2001-11-07 20:16:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
The default cron job for the slocate package (/etc/cron.daily/slocate.cron)
calls "locate" using the updatedb symlink.  

When this runs on a machine with ext3 filesystems the resulting slocate.db
(/var/lib/slocate/slocate.db) is about 1byte in size.  It seems to only
contain the ascii digit "1".

In the man page for updatedb it is stated that locate simply runs with the
-u option when called as updatedb.  

There's clearly more going on here, since the following change to
/etc/cron.daily/slocate.cron seems to fix the problem:

[ Original line ]
/usr/bin/updatedb -f "nfs,smbfs,ncpfs,proc,devpts" -e
"/tmp,/var/tmp,/usr/tmp,/afs,/net"
[ Modified line ] 
/usr/bin/locate -u -f "nfs,smbfs,ncpfs,proc,devpts" -e
"/tmp,/var/tmp,/usr/tmp,/afs,/net"


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Upgrade to RH 7.2
2.Run the default slocate.cron in /etc/cron.daily
3.Find that /var/lib/slocate/slocate.db is now a nearly empty file
	

Actual Results:  My slocate.db file becomes a 1 byte file containing the
number "1".

Expected Results:  My slocated.db should have been updated to contain a
nice big index of my filesystems.


Additional info:

This happens on a Red Hat 7.1 box that has been retrofitted with ext3
filesystems as well.

Comment 1 Bill Nottingham 2002-01-25 05:44:13 UTC
This works fine for me on ext3; I get a normal sized file.

What happens if you strace the call to slocate?

Comment 2 Bill Nottingham 2002-01-25 07:11:18 UTC
Also, do you have your filesystem set to 'auto' in /etc/fstab?

Comment 3 Leigh L. Klotz, Jr. 2002-02-12 01:53:17 UTC
This happens to me in RedHat 7.2 as well, if the root file system is auto.  I
edited /etc/mtab by hand and changed 'auto' to 'ext3' and re-ran
/etc/cron.daily/slocate.cron and it worked fine.  BTW, even though I have 'auto'
in /etc/fstab for all of my ext3 file systems, only the / filesystem showed up
as auto in /etc/mtab.



Comment 4 Thomas Woerner 2004-10-15 18:45:33 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.



Note You need to log in before you can comment on or make changes to this bug.