This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 558562 - superfluous Samba data is written to /etc/samba/smb.conf
superfluous Samba data is written to /etc/samba/smb.conf
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Configuration (Show other bugs)
1.4
All Linux
low Severity high (vote)
: ---
: ---
Assigned To: Ian Springer
John Sefler
: SubBug
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2010-01-25 12:11 EST by John Sefler
Modified: 2013-08-05 20:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-16 14:20:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2010-01-25 12:11:33 EST
Description of problem:
When creating a Samba share through iManage, an unexpected parameter is being set within the share's section name.

Version-Release number of selected component (if applicable):

How reproducible:
always

Steps to Reproduce:
1. Create a Samba share through the iManage UI.  Set the following UI fields:
Resource Name:  testResourceName
Name:           testName
Path:           /tmp/testNameShare
click Submit
2. On the agent's filesystem:
cat /etc/samba/smb.cnf

Notice the newly added samba section [testName].  The "name = testName" parameter is superfluous and unrecognised by samba's own testparm configuration checking tool.

Actual results:
[testName]
   name = testName
   path = /tmp/testNameShare

Expected results:
[testName]
   path = /tmp/testNameShare

Additional info:
Try running on the command line:
testparm -sv --section-name=testName

Processing section "[testName]"
Unknown parameter encountered: "name"
Ignoring unknown parameter "name"
Loaded services file OK.
[testName]
	path = /tmp/testNameShare
Comment 1 wes hayutin 2010-02-16 11:52:04 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 2 wes hayutin 2010-02-16 11:58:01 EST
making sure we're not missing any bugs in rhq_triage
Comment 3 Corey Welton 2010-09-13 16:17:26 EDT
ps -- can we do semantic validation when a config is saved?
Comment 4 Corey Welton 2010-09-13 16:17:53 EDT
s/ps/ips/  -- that question was directed at you, ian :)
Comment 5 Ian Springer 2011-02-16 14:18:59 EST
Corey, yes, when the user clicks the Save button, updateConfiguration() is called on the plugin, and if the plugin finds issues with certain property values, it can set validation error messages on those properties and then send back a failed response to the Server, which includes the property-specific errors. The GUI will then display the property-specific errors next to the corresponding properties.
Comment 6 Ian Springer 2011-02-16 14:20:03 EST
Closing this, since the samba and other Linux plugins are no longer a priority.

Note You need to log in before you can comment on or make changes to this bug.